Arkusze kalkulacyjne — informacje

Arkusza kalkulacyjnego można używać do wprowadzania i obliczania danych. Arkusz kalkulacyjny składa się z kolumn i wierszy komórek. Dane można wprowadzać bezpośrednio w komórkach arkusza kalkulacyjnego i wykonywać za pomocą formuł obliczenia na podstawie tych danych. Utworzenie interaktywnego arkusza kalkulacyjnego za pomocą jednego z programów do projektowania pakietu Microsoft Office XP i umieszczenie tego arkusza kalkulacyjnego na stronie sieci Web daje użytkownikom sieci Web możliwość interaktywnej pracy z danymi i wykonywania obliczeń bezpośrednio w przeglądarce. Użytkownicy mogą dokonywać zmian danych i przeglądać automatycznie wyświetlane wyniki obliczeń.

Poniższy przykład to arkusz kalkulacyjny na stronie sieci Web, zaprojektowany do użytku jako kalkulator pożyczki hipotecznej. Gdy użytkownik zmieni wartości w obramowanych komórkach wejściowych w przeglądarce, arkusz kalkulacyjny obliczy spłatę pożyczki hipotecznej.

Arkusz kalkulacyjny na stronie sieci Web

Wymagania dotyczące przeglądarki i licencji

Aby przeglądać i pracować z interakcyjnym arkuszem kalkulacyjnym w przeglądarce, użytkownicy muszą zainstalować składniki Microsoft Office Web Components. Można to zrobić, instalując pakiet Microsoft Office XP lub, jeżeli firma ma licencję pakietu Office XP na lokację, pobierając składniki Microsoft Office Web Components z sieci intranet. Użytkownicy muszą również korzystać z programu Microsoft Internet Explorer w wersji 4.01 lub nowszej.

Programy do projektowania, których można użyć do utworzenia lub zmodyfikowania arkuszy kalkulacyjnych

Arkusze kalkulacyjne można utworzyć i zmodyfikować w kilku programach. Użytkownik może utworzyć arkusz kalkulacyjny w jednym programie i później użyć innego programu do zmodyfikowania arkusza kalkulacyjnego lub strony sieci Web, na której znajduje się arkusz kalkulacyjny.

Wybór programu do projektowania zależy od wielkości pracy związanej z projektowaniem lub administrowaniem stroną sieci Web, typu danych, które mają być używane, a także od zaznajomienia użytkownika z różnymi programami do projektowania.

Program Microsoft Excel Ten program jest doskonałym środowiskiem projektowym, które może być używane do tworzenia arkuszy kalkulacyjnych, jeżeli projektant chce wypróbować różne formuły, dostosować odwołania, importować dane z innych źródeł lub zaprojektować interaktywne wykresy odzwierciedlające dane w arkuszu kalkulacyjnym.

Projektant może sformatować arkusz kalkulacyjny oraz dostosować jego rozmiar i wygląd w innym programie do projektowania. Jeżeli którykolwiek z użytkowników ma program Microsoft Internet Explorer w wersji 4.01, należy użyć programu Microsoft FrontPage do zmodyfikowania arkuszy kalkulacyjnych opublikowanych za pomocą programu Excel. Program Excel publikuje arkusze kalkulacyjne jako strony sieci Web z pełną obsługą programu Internet Explorer w wersji 4.01 i nowszych, a program FrontPage zapewnia tę obsługę. Jeżeli strona sieci Web opublikowana za pomocą programu Excel jest modyfikowana w widoku Projekt strony dostępu do danych w programie Microsoft Access, to konieczne może być zainstalowanie programu Internet Explorer w wersji 5 lub nowszej, aby użytkownicy mogli korzystać z danej strony sieci Web. Program Excel jest dostępny w pakiecie Microsoft Office XP.

Program Microsoft FrontPage Do tworzenia strony sieci Web lub zmodyfikowania arkuszy kalkulacyjnych opublikowanych z programu Excel zalecanym programem projektowym jest program FrontPage. W programie FrontPage, oprócz modyfikowania arkuszy kalkulacyjnych zaprojektowanych w innych programach, można utworzyć arkusze kalkulacyjne na stronach sieci Web. Można użyć rozbudowanych funkcji administracyjnych i edytowania stron sieci Web programu Microsoft FrontPage, aby dodać formanty, grafikę, motywy i wiele innych elementów do stron sieci Web, a następnie dodać stronę do witryny sieci Web jako jej część. Program Microsoft FrontPage jest dostępny w pakiecie Microsoft Office XP.

Program Microsoft Access W celu utworzenia stron sieci Web używających i wyświetlających bazy danych, gdy użytkownicy korzystają z programu Internet Explorer w wersji 5 lub nowszej, do utworzenia arkuszy kalkulacyjnych należy użyć widoku Projektu strony dostępu do danych w programie Access. Program Access może być użyty do ustanowienia połączenia między bazą danych programu Access i stroną sieci Web, a następnie formuł w arkuszu kalkulacyjnym można użyć do zwrócenia wartości z bazy danych do arkusza kalkulacyjnego. Program Microsoft Access jest dostępny w pakiecie Microsoft Office XP.

Program Visual Basic Jeżeli potrzebne jest środowisko programowania bardziej zaawansowane niż środowiska skryptów w programach Excel, FrontPage i Access, to można zaprojektować arkusze kalkulacyjne w programie Visual Basic. Programu Visual Basic należy używać wówczas, gdy konieczne jest uwzględnienie arkusza kalkulacyjnego lub aparatu obliczeniowego w rozwiązaniu niestandardowym. Użytkownicy mogą przeglądać arkusze kalkulacyjne znajdujące się na formularzach Visual Basic i pracować interaktywnie z tymi arkuszami w używanych programach. Zamiast przeglądarki formularz staje się środowiskiem czasu uruchomienia, a program może automatyzować wiele funkcji arkusza kalkulacyjnego lub funkcji obliczeniowych.

Tworzenie i dostosowywanie arkusza kalkulacyjnego

Aby utworzyć arkusz kalkulacyjny, należy postępować zgodnie z instrukcjami programu do projektowania dotyczącymi umieszczenia arkusza kalkulacyjnego na stronie sieci Web. Następnie można wprowadzić dane i formuły w arkuszu kalkulacyjnym lub importować dane do użytku w arkuszu kalkulacyjnym. Aby utworzyć arkusz kalkulacyjny w programie Microsoft Excel, należy zapoznać się z Pomocą dotyczącą zapisywania lub publikowania arkuszy w programie Excel.

Korzystanie z paska narzędzi arkusza kalkulacyjnego oraz okna dialogowego Polecenia i opcje Po utworzeniu arkusza kalkulacyjnego można zmienić opcje formatowania i wyświetlania, ustawić rozmiar arkusza kalkulacyjnego, chronić komórki i wykonać wiele innych czynności przy użyciu okna dialogowego Polecenia i opcje i paska narzędzi arkusza kalkulacyjnego.

Ograniczanie dostępu w przeglądarce Nawet w przeglądarce z pełną obsługą arkuszy kalkulacyjnych, takiej jak program Microsoft Internet Explorer 5, użytkownicy nie mają dostępu do niektórych poleceń i funkcji, z których można korzystać w programie do projektowania. Aby uniemożliwić użytkownikom dokonywanie zmian danych lub formuł w arkuszu kalkulacyjnym, można ustawić dodatkowe ograniczenia.

Dołączanie instrukcji Opisowy tekst, instrukcje i inne informacje o arkuszu kalkulacyjnym można dodać w widocznym miejscu w arkuszu kalkulacyjnym lub na stronie sieci Web.

Dołączanie wykresu Można również wyświetlić wykres danych znajdujących się w arkuszu kalkulacyjnym lub na stronie sieci Web. Gdy użytkownik zmieni dane wyświetlane w arkuszu kalkulacyjnym w przeglądarce, wykres zostanie automatycznie zaktualizowany. Na przykład, jeżeli arkusz kalkulacyjny zawiera tabelę amortyzacji używającą formuł do obliczania spłat pożyczki hipotecznej, to można dołączyć interaktywny wykres na stronie sieci Web pokazujący porównanie kapitału i spłat odsetek w funkcji czasu. Jeżeli użytkownik zmieni stopę oprocentowania lub wartość spłat gotówkowych wykorzystane w formule, to formuły arkusza kalkulacyjnego zaktualizują informacje, a wykres zostanie zaktualizowany tak, aby odzwierciedlać najnowsze liczby.

Automatyzacja Za pomocą skryptów można uzyskać dostęp do wielu funkcji i możliwości arkusza kalkulacyjnego oraz sterować tymi funkcjami. Osoby zaznajomione z pisaniem skryptów dla stron sieci Web w języku takim jak Microsoft Visual Basic Scripting Edition (VBScript) lub JavaScript mogą dodać skrypty do arkusza kalkulacyjnego w celu wykonania takich operacji jak pobieranie wartości z bazy danych i obliczanie informacji w tle.

Programy pakietu Microsoft Office zawierają program Microsoft Script Editor służący do tworzenia i modyfikowania skryptów. Aby uzyskać informacje na temat pisania skryptów, należy zapoznać się z Pomocą programu do projektowania.

Testowanie i publikowanie

Sprawdzanie arkusza kalkulacyjnego w przeglądarce Przed udostępnieniem arkusza kalkulacyjnego użytkownikom należy przetestować go w przeglądarce. Jeżeli użytkownicy mają różne wersje przeglądarek, konieczne może być przetestowanie arkusza kalkulacyjnego w każdej z wersji, aby upewnić się, że informacje są poprawnie wyświetlane i aktualizowane.

Dokonywanie zmian Jeżeli arkusz kalkulacyjny lub strona sieci Web nie są zadowalające, można powrócić do programu do projektowania i dokonać zmian. Na przykład, jeżeli arkusz kalkulacyjny został opublikowany za pomocą programu Microsoft Excel, to aby dokonać zmian można otworzyć stronę sieci Web zawierającą arkusz kalkulacyjny w programie Microsoft FrontPage.

Publikowanie strony sieci Web Jeżeli wyniki są zadowalające, należy udostępnić stronę sieci Web użytkownikom. Należy zapoznać się z Pomocą programu do projektowania, aby uzyskać informacje dotyczące publikowania stron sieci Web lub skonsultować się z Webmasterem.


Przeglądarki obsługujące arkusze kalkulacyjne

Aby pracować interakcyjnie z arkuszami kalkulacyjnymi w programie Microsoft Internet Explorer w wersji 4.01 i nowszej, należy zainstalować składniki Microsoft Office Web Component na komputerach użytkowników oraz posiadać odpowiednią licencję Office XP. Użytkownicy, którzy nie mają licencji Office XP, mogą zainstalować wspomniane składniki i przeglądać je na stronie sieci Web, ale nie mogą interakcyjnie z nimi pracować. Dowiedz się więcej o instalowaniu i licencjonowaniu składników.

Poniżej przedstawiono poziomy obsługi w przeglądarce, przy założeniu że użytkownik ma składniki Microsoft Office Web Components oraz licencję Office XP.

Program Microsoft Internet Explorer 5 i nowszy

Użytkownicy mogą korzystać ze wszystkich funkcji arkusza kalkulacyjnego dostępnych z poziomu przeglądarki. Do tworzenia arkusza kalkulacyjnego za pomocą strony dostępu do danych w widoku Projekt programu Microsoft Access 2000 lub modyfikowania arkusza kalkulacyjnego i zapisywania strony sieci Web za pomocą programu Access wymagany jest program Internet Explorer 5.

Program Microsoft Internet Explorer 4.01, 4.1x i 4.2x

Użytkownicy mogą korzystać ze wszystkich funkcji arkusza kalkulacyjnego dostępnych z poziomu przeglądarki, z wyjątkiem przypadków, gdy strona sieci Web została utworzona lub zmodyfikowana i zapisana na stronie dostępu do danych w widoku Projekt programu Microsoft Access. Aby uzyskać dostęp do wszystkich funkcji wymagany jest wtedy program Internet Explorer 5.

Inne przeglądarki

We wcześniejszych wersjach programu Microsoft Internet Explorer i w innych przeglądarkach użytkownicy nie mogą wyświetlać interakcyjnych arkuszy kalkulacyjnych. Arkusz kalkulacyjny pojawia się na stronie stronie sieci Web w postaci pola otoczonego konturem.


Korzystanie z arkusza kalkulacyjnego w przeglądarce — informacje

W tym temacie objaśniono, w jaki sposób użytkownicy mogą w przeglądarce sieci Web Microsoft Internet Explorer interaktywnie pracować z arkuszem kalkulacyjnym utworzonym przez projektanta. Opis funkcji arkuszy kalkulacyjnych dostępnych w przeglądarce ułatwić ma projektowanie arkuszy kalkulacyjnych zgodnie z potrzebami użytkowników.

Praca w przeglądarce w porównaniu do pracy w programie do projektowania

Składnik Spreadsheet Component umożliwia utworzenie w programie do projektowania arkusza kalkulacyjnego, który będzie dostępny w czasie uruchomienia w przeglądarce sieci Web lub innym środowisku czasu uruchomienia. Programy Microsoft Excel, Microsoft FrontPage i Microsoft Access są programami do projektowania, których można użyć do tworzenia i modyfikowania arkuszy kalkulacyjnych.

Funkcje czasu uruchomienia omówione w tym temacie są dostępne dla użytkowników, którzy zainstalowali składniki Microsoft Office Web Components. Można tego dokonać, instalując pakiet Microsoft Office XP lub, jeżeli firma ma licencję na lokację pakietu Office XP, pobierając składniki Office Web Components z firmowej sieci intranet. Użytkownicy powinni również mieć przeglądarkę sieci Web, taką jak Internet Explorer w wersji 4.01 lub nowszej, z pełną obsługą interaktywnych arkuszy kalkulacyjnych. Jeżeli planowane jest utworzenie arkuszy kalkulacyjnych do użytku w programie innym niż przeglądarka sieci Web, na przykład w formularzu programu Microsoft Visual Basic przeznaczonym do przeglądania jako część niestandardowego rozwiązania, należy zapoznać się z Pomocą programu do projektowania, aby dowiedzieć się, w jaki sposób użytkownicy mogą uzyskać dostęp do arkusza kalkulacyjnego i pracować z nim interaktywnie.

Co użytkownicy mogą zrobić w przeglądarce

Aby przeglądać i pracować w pełni interaktywnie z arkuszem kalkulacyjnym na stronie sieci Web, użytkownicy muszą mieć program Microsoft Internet Explorer w wersji 4.01 lub nowszej i odpowiednią licencję pakietu Office.

Użytkownicy mogą interaktywnie pracować z arkuszem kalkulacyjnym W przeglądarce w czasie uruchomienia użytkownicy mogą uaktywniać arkusz kalkulacyjny i pracować z nim interaktywnie przy użyciu tego samego paska narzędzi i okna dialogowego Polecenia i opcje, które są używane podczas projektowania arkusza kalkulacyjnego. Użytkownicy korzystający z przeglądarki nie mają jednak dostępu do niektórych funkcji dostępnych dla projektanta w programie do projektowania, w tym do importowania danych, włączania lub wyłączania ochrony i zaawansowanych funkcji, takich jak ustawianie widocznego zakresu arkusza kalkulacyjnego.

Użytkownicy mogą wprowadzać i obliczać dane Z uwzględnieniem wszelkich ograniczeń określonych podczas projektowania arkusza kalkulacyjnego, użytkownicy mogą dodawać, usuwać lub zmieniać dane; tworzyć lub modyfikować formuły, a także stosować opcje formatowania — tak, jak jest to możliwe w programie do projektowania.

Użytkownicy mają dostęp do Pomocy Użytkownik przeglądarki ma dostęp do dwóch typów Pomocy: systemu Pomocy w przeglądarce i dodatkowej Pomocy dołączonej do arkusza kalkulacyjnego. Druga z nich wyjaśnia, w jaki sposób należy używać poleceń i funkcji dostępnych w arkuszu kalkulacyjnym. Aby przeglądać tę Pomoc w czasie uruchomienia, należy uaktywnić arkusz kalkulacyjny w przeglądarce, a następnie kliknąć przycisk Pomoc [image] na pasku narzędzi arkusza kalkulacyjnego. Można również dołączyć instrukcje niestandardowe dotyczące arkusza kalkulacyjnego wyświetlanego w przeglądarce.

Ograniczanie czynności, które użytkownicy mogą wykonać w przeglądarce

Można ograniczyć czynności, które użytkownicy mogą wykonać w przeglądarce, ustawiając opcje ochrony, takie jak blokowanie komórek, kontrolowanie wyświetlania paska narzędzi lub okna dialogowego Polecenia i opcje oraz kontrolowanie obszarów arkusza kalkulacyjnego, które można przeglądać.


Składniki Microsoft Office Web Components — informacje

Składniki Microsoft Office Web Components to zestaw formantów ActiveX instalowanych razem z pakietem Microsoft Office XP. Po zainstalowaniu składników Office Web Components można za pomocą przeglądarki Microsoft Internet Explorer 4.01 lub nowszej interakcyjnie korzystać z arkusza kalkulacyjnego, listy tabeli przestawnej i wykresu na stronie sieci Web. Chcąc używać składników na stronie dostępu do danych w programie Microsoft Access, trzeba zainstalować przeglądarkę Internet Explorer 5 lub nowszą.

Jeśli na komputerze nie zainstalowano składników Office Web Components, ale posiadana jest licencja Office XP, która umożliwia dystrybucję w sieci intranet, to można tak skonfigurować składniki, aby użytkownicy byli monitowani o ich pobranie z firmowej sieci intranet. Pozwala to użytkownikom korzystać ze strony dostępu do danych bez instalacji oprogramowania Office XP na komputerach.

Informacje na temat konfigurowania składników Office Web Components można znaleźć w zestawie Microsoft Office XP Resource Kit.


Instalowanie, licencjonowanie i rozpowszechnianie składników Office Web Components

Gdy zaprojektujesz stronę sieci Web za pomocą składników Office Web Components, każdy użytkownik posiadający licencję pakietu Office XP będzie mógł interaktywnie pracować ze składnikami w przeglądarce, ale do zadeklarowanego przez projektanta poziomu interaktywności. To znaczy, że użytkownik z odpowiednią licencją może zmieniać dane w arkuszu kalkulacyjnym, zmieniać formatowanie, przeciągać pola na wykresie lub liście tabeli przestawnej i tak dalej, jeśli opcje te nie zostaną zastrzeżone podczas projektowania. Użytkownicy posiadający licencję pakietu Office XP mogą także tworzyć, projektować i modyfikować składniki w środowisku projektowania, takim jak programy Microsoft FrontPage lub Microsoft Access.

Użytkownicy nie posiadający licencji pakietu Office XP mogą wyświetlić składniki i zawarte w nich dane, mogą też wydrukować widok składników, ale nie mogą interaktywnie pracować ze składnikami ani operować nimi w środowisku projektowania. To znaczy, że gdy rozpowszechniana jest strona sieci Web wykorzystująca składniki, wówczas użytkownicy mający licencje pakietu Office XP, będą mieli dostęp do wszystkich funkcji, a użytkownicy bez licencji będą mogli jedynie wyświetlać dane i informacje, o ile są one podane.

Instalowanie składników Microsoft Office Web Components

Składniki Microsoft Office Web Components są instalowane wraz z pakietem Microsoft Office XP i aplikacjami pakietu Microsoft Office lub mogą być zainstalowane oddzielnie z punktu instalacyjnego udostępnianego przez projektanta strony sieci Web.

Gdy rozpowszechniana jest strona sieci Web wykorzystująca składniki, wówczas użytkownicy, którzy nie mają zainstalowanych składników będą monitowani o zainstalowanie składników, o ile projektant strony sieci Web odpowiednio skonfiguruje składniki. Projektant strony sieci Web musi także udostępnić punkt instalacyjny składników i wskaźnik do tej lokalizacji na stronie instalacyjnej składników. Aby uzyskać więcej informacji, zapoznaj się z zestawem Microsoft Office XP Resource Kit.

Po zainstalowaniu składników Microsoft Office Web Components użytkownicy, którzy mają dostęp do licencji pakietu Office XP będą mogli pracować interaktywnie ze składnikami i dokonywać w nich zmian. Użytkownicy bez licencji będą mogli wyświetlać i drukować składniki i zawarte w nich dane, ale nie będą mogli pracować interaktywnie ani dokonywać zmian.

Szczegółowe informacje o licencjonowaniu i funkcjach

Pakiet Microsoft Office XP zainstalowany na komputerze Użytkownicy dysponują wszystkimi funkcjami i mogą interaktywnie pracować ze składnikami, włącznie z funkcjami czasu uruchomienia i czasu projektowania.

Aplikacja pakietu Microsoft Office XP zainstalowana na komputerze Użytkownicy mogą pracować interaktywnie ze składnikiem w trybie projektowania jedynie w tej aplikacji (a nie w przeglądarce ani w innych aplikacjach).

Licencja pakietu Microsoft Office XP w trybie dostępu z lokalizacji (użytkownik nie ma zainstalowanego na swoim komputerze pakietu Office XP, ale organizacja lub przedsiębiorstwo mają umowę licencyjną w trybie dostępu z lokalizacji) Użytkownicy dysponują wszystkimi funkcjami i mogą pracować interaktywnie ze składnikami, włącznie z funkcjami czasu uruchomienia i czasu projektowania. Projektant strony sieci Web musi natomiast podać lokalizację, z której można pobrać składniki oraz musi odwołać się do licencji w trybie dostępu z lokalizacji w pliku pakietu licencji (.lpk), który jest skojarzony z co najmniej jedną stroną sieci Web. Do utworzenia odpowiedniego pliku licencji stron służy narzędzie License Package Authoring Tool. Więcej informacje można znaleźć w witrynie MSDN Online.

Brak pakietu Microsoft Office XP, aplikacji pakietu Microsoft Office XP lub licencji w trybie dostępu z lokalizacji Użytkownicy mogą wyświetlać i drukować składniki w trybie tylko do przeglądania, ale nie mogą pracować interaktywnie ze składnikami ani używać funkcji projektowania.


Tryb tylko do wyświetlania składników Office Web Components — informacje

Jeśli na komputerze nie zainstalowano licencji na użytkowanie oprogramowania Microsoft Office XP ani nie jest ona dostępna za pośrednictwem aplikacji Microsoft Office XP, to na stronie sieci Web można wyświetlać składniki Microsoft Office Web Component — Arkusz kalkulacyjny, Wykres lub Tabelę przestawną — ale nie można z nimi interakcyjnie pracować.

Aby interakcyjnie i w pełni korzystać z funkcji wyświetlanych składników, należy zainstalować pakiet Microsoft Office XP albo uzyskać licencję Office XP. Osoby pracujące w firmie lub w środowisku grupowym powinny poprosić o pomoc administratora sieci.

Pracując w trybie tylko do wyświetlania, można:

  • wyświetlać dane,
  • drukować,
  • zaznaczać i przewijać,
  • korzystać z hiperłączy,
  • zmieniać rozmiar składnika,
  • zaznaczać arkusze w składniku Arkusz kalkulacyjny,
  • rozwijać lub zwijać człony listy tabeli przestawnej,
  • odświeżać dane na liście tabeli przestawnej,
  • korzystać z poleceń Informacje, Pomoc i Odśwież. Niedostępne są tematy Pomocy dotyczące interakcji (na przykład formatowania komórek, przeciągania pól, sortowania, filtrowania i tak dalej).

W trybie tylko do wyświetlania niedostępne są wszystkie polecenia z wyjątkiem poleceń Informacje, Pomoc i Odśwież.


Uzyskiwanie pomocy dla arkuszy kalkulacyjnych — informacje

Niektóre informacje podane w tym temacie mogą nie mieć zastosowania w przypadku niektórych języków.

Uzyskiwanie pomocy w innych programach projektowych

Podczas pracy w programie projektowym pomoc można uzyskać w następujący sposób:

  • Pomoc programu projektowego Informacje na temat poleceń i funkcji dostępnych w programie projektowym i służących do pracy z arkuszami kalkulacyjnymi można znaleźć w Pomocy programu projektowego. Na przykład, w programie Microsoft FrontPage można kliknąć Asystenta pakietu Office lub przycisk Microsoft FrontPage — Pomoc [image].

    Program Microsoft Excel zawiera zarówno pomoc ogólną, dotyczącą zapisywania danych programu Excel w celu ich wykorzystania na stronach sieci Web, jak i specyficzne informacje na temat zapisywania arkuszy kalkulacyjnych w celu ich użycia na stronach sieci Web. Aby uzyskać dostęp do Pomocy w programie Excel, kliknij Asystenta pakietu Office lub przycisk Microsoft Excel — Pomoc [image].

  • Pomoc w fazie projektowania arkusza kalkulacyjnego Jeśli w innym programie projektowym dostępne jest okno dialogowe Polecenia i opcje, to dostępne są również niniejsze tematy Pomocy. W arkuszu kalkulacyjnym utworzonym lub uaktywnionym w programie projektowym, kliknij przycisk Pomoc [image] w oknie dialogowym Polecenia i opcje lub przycisk Pomoc na pasku narzędzi arkusza kalkulacyjnego.

Uzyskiwanie pomocy dotyczącej pisania skryptów i programów używających arkuszy kalkulacyjnych

Skryptów i programów można użyć do automatyzowania arkuszy kalkulacyjnych; arkusze kalkulacyjne można też dołączyć do uruchomionych programów, innych niż przeglądarki sieci Web — programów opracowywanych w środowiskach programowania, na przykład Microsoft Visual Basic.

Pisanie skryptów Programy pakietu Microsoft Office zawierają edytor Microsoft Script Editor ułatwiający pisanie skryptów. Edytora Script Editor można, na przykład, użyć w programie Microsoft FrontPage, aby dostosować arkusz kalkulacyjny. Informacje na temat uruchamiania edytora Script Editor można znaleźć w Pomocy programu projektowego pakietu Office. W edytorze Script Editor można wyświetlić dodatkową pomoc dotyczącą używania funkcji edytora i pisania skryptów.

Pomoc modelu obiektowego Aby uzyskać pomoc dotyczącą opracowywania programu lub skryptu, który ma pracować z arkuszem kalkulacyjnym, można wyświetlić informacje na temat modelu obiektowego, właściwości i metod specyficznych dla arkuszy kalkulacyjnych. Pomoc modelu obiektowego jest instalowana razem z pakietem Microsoft Office Web Components, którego częścią jest arkusz kalkulacyjny. W zależności od używanego programu projektowego, dostęp do tej Pomocy można uzyskać na dwa sposoby:

  • Pomoc w programie Microsoft Visual Basic W programie Visual Basic lub Visual Basic for Applications (VBA) można utworzyć odwołanie do biblioteki Office Web Components. Dostęp do Pomocy można uzyskać za pomocą przeglądarki obiektów lub po zaznaczeniu słowa kluczowego i naciśnięciu klawisza F1. Informacje na temat tworzenia odwołań i używania Pomocy modelu obiektowego można znaleźć w Pomocy programu Visual Basic lub VBA.
  • Pomoc w innych środowiskach W przypadku używania innego środowiska projektowego należy zlokalizować i kliknąć dwukrotnie plik Pomocy owcvba10.chm.

Uzyskiwanie i udostępnianie pomocy w przeglądarce

W przeglądarce Pomoc wyjaśnia, jak używać funkcji i możliwości arkuszy kalkulacyjnych. W zależności od umiejętności użytkowników oraz od typu zadań, które chcą wykonywać, pomoc tę można uzupełnić, dodając na stronie sieci Web niestandardowe instrukcje dla arkusza kalkulacyjnego lub udostępniając hiperłącze do zawierającej takie instrukcje strony sieci Web.

Pomoc dostępna w przeglądarce Użytkownicy posiadający program Microsoft Internet Explorer w wersji 4.01 lub nowszej oraz pakiet Microsoft Office Web Components automatycznie uzyskują dostęp do ogólnej Pomocy dotyczącej arkuszy kalkulacyjnych. Pomoc ta, dostępna w czasie działania programu, jest niezależna od Pomocy dostępnej w menu Pomoc przeglądarki.

Tematy Pomocy, dostępne w czasie działania programu, zawierają informacje ogólne, przeznaczone dla wszystkich użytkowników, a dotyczące korzystania z arkuszy kalkulacyjnych w przeglądarce — różnią się one od niniejszych tematów Pomocy dotyczących projektowania arkuszy kalkulacyjnych. Pozostałe składniki pakietu Office Web Components, na przykład PivotTable Component (Tabela przestawna), również zawierają własną Pomoc dostępną w przeglądarce.

Aby zobaczyć Pomoc dostępną w przeglądarce, należy utworzyć arkusz kalkulacyjny na stronie sieci Web, otworzyć tę stronę w programie Internet Explorer, kliknąć arkusz kalkulacyjny, a następnie kliknąć przycisk Pomoc [image] na pasku narzędzi arkusza kalkulacyjnego. W oknie Pomocy można wyświetlić spis treści i przeszukać tekst tematu. Asystent pakietu Office nie odpowiada na pytania, ponieważ nie jest dostępny w przeglądarce.


Skróty klawiaturowe w arkuszach kalkulacyjnych

Informacje o klawiszach aktywujących i dezaktywujących składnik Arkusz kalkulacyjny pakietu Microsoft Office na stronie sieci Web można znaleźć w Pomocy programu do projektowania.

Klawisze do przenoszenia się i przewijania w arkuszu kalkulacyjnym

Klawisze strzałek
Przenosi o jedną komórkę w górę, w dół, w prawo lub w lewo
CTRL + klawisz strzałki
Przenosi do krawędzi bieżącego regionu danych
HOME
Przenosi do początku wiersza
CTRL+HOME
Przenosi do początku arkusza
CTRL+END
Przenosi do ostatniej komórki w arkuszu, znajdującej się na przecięciu najdalszej, położonej na prawo, używanej kolumny i położonego najniżej używanego wiersza (w prawym-dolnym rogu) lub do komórki leżącej naprzeciwko komórki początkowej, którą zwykle jest A1
PGDN
Przenosi o jeden ekran w dół
PAGE UP
Przenosi o jeden ekran w górę
ALT+PGDN
Przenosi o jeden ekran w prawo
ALT+PGUP
Przenosi o jeden ekran w lewo
CTRL+PAGE DOWN
Przenosi do następnego arkusza
CTRL+PAGE UP
Przenosi do poprzedniego arkusza
Klawisz TAB
Przenosi do przodu pomiędzy odblokowanymi komórkami w chronionym arkuszu
SHIFT+TAB
Przenosi wstecz między odblokowanymi komórkami w chronionym arkuszu

Klawisze do przemieszczania się przy włączonym klawiszu SCROLL LOCK

SCROLL LOCK
Włącza lub wyłącza tryb SCROLL LOCK.
STRZAŁKA W GÓRĘ albo STRZAŁKA W DÓŁ
Przewija ekran o jeden wiersz w górę lub w dół
STRZAŁKA W LEWO lub STRZAŁKA W PRAWO
Przewija o jedną kolumnę w lewo lub w prawo

Klawisze do pracy z arkuszami

SHIFT+F11
Wstawia nowy arkusz
CTRL+PAGE DOWN
Przenosi do następnego arkusza
CTRL+PAGE UP
Przenosi do poprzedniego arkusza

Klawisze do wprowadzania danych w arkuszu

ENTER
Kończy wprowadzanie zawartości do komórki i przenosi w dół w zaznaczeniu
CTRL+ENTER
Wypełnia zaznaczony zakres komórek bieżącym wpisem
SHIFT+ENTER
Kończy wprowadzanie zawartości do komórki i przenosi w górę w zaznaczeniu
Klawisz TAB
Kończy wprowadzanie zawartości do komórki i przenosi w prawo w zaznaczeniu
CTRL+SHIFT+ENTER
Wprowadza formułę tablicową
SHIFT+TAB
Kończy wprowadzanie zawartości do komórki i przenosi w lewo w zaznaczeniu
ESC
Powoduje anulowanie wpisu do komórki
Klawisze strzałek
Przenosi o jeden znak w lewo lub w prawo
HOME
Przenosi do początku wiersza
END
Przenosi na koniec wiersza
ALT+0128 (na klawiaturze numerycznej przy włączonym klawiszu Num Lock)
Wprowadza znak waluty euro Symbol waluty euro

Klawisze do pracy z komórkami

F2
Umożliwia edytowanie aktywnej komórki i pozycjonuje punkt wstawiania na końcu zawartości komórki
F9
Powoduje obliczenie wszystkich arkuszy w aktywnym arkuszu kalkulacyjnym
= (znak równości)
Rozpoczyna formułę
ALT+= (znak równości)
Wstawia formułę SUMA za pomocą polecenia Autosumowanie
BACKSPACE
Usuwa znak na prawo od punktu wstawiania lub usuwa zaznaczenie
DELETE
Usuwa znak na prawo od punktu wstawiania lub usuwa zaznaczenie

Klawisze do formatowania danych

CTRL+B
Powoduje zastosowanie lub usunięcie formatowania pogrubionego
CTRL+I
Powoduje zastosowanie lub usunięcie formatowania kursywą
CTRL+U
Powoduje zastosowanie lub usunięcie podkreślenia

Klawisze do edytowania danych

F2
Umożliwia edytowanie aktywnej komórki i umieszcza punkt wstawiania na końcu wiersza
F4
Przełącza pomiędzy trybem bezwzględnym i względnym dla aktualnie zaznaczonego odwołania
ESC
Powoduje anulowanie wpisu do komórki
BACKSPACE
Powoduje wyczyszczenie aktywnej komórki i pozostawienie w trybie edycji lub usunięcie poprzedniego znaku w aktywnej komórce podczas edytowania zawartości komórki
ENTER
Kończy edytowanie zawartości komórki
CTRL+SHIFT+ENTER
Wprowadza formułę jako formułę tablicową

Klawisze do wstawiania, usuwania i kopiowania zaznaczenia

CTRL+C
Kopiuje zaznaczenie
CTRL+X
Wycina zaznaczenie
CTRL+V
Wkleja zaznaczenie
DELETE
Wyczyszczenie zawartości zaznaczenia
CTRL+Z
Powoduje cofnięcie ostatniej akcji

Klawisze do przenoszenia się obrębie zaznaczenia

ENTER
Przenosi z góry na dół w obrębie zaznaczenia lub przenosi w kierunku wybranym w oknie dialogowym Polecenia i opcje
SHIFT+ENTER
Przenosi z dołu do góry w obrębie zaznaczenia lub przenosi w kierunku przeciwnym do wybranego w oknie dialogowym Polecenia i opcje
Klawisz TAB
Przenosi od lewej do prawej w obrębie zaznaczenia lub przenosi o jedną komórkę w dół, jeśli zaznaczona jest tylko jedna kolumna
SHIFT+TAB
Przenosi od prawej do lewej w obrębie zaznaczenia lub przenosi o jedną komórkę w górę, jeśli zaznaczona jest tylko jedna kolumna

Klawisze do zaznaczania komórek, kolumn lub wierszy

SHIFT+klawisz strzałki
Rozszerza zaznaczenie o jedną komórkę
CTRL+SHIFT+klawisz strzałki
Rozszerza zaznaczenie do ostatniej niepustej komórki w tej samej kolumnie lub tym samym wierszu, w którym jest aktywna komórka
SHIFT+HOME
Rozszerza zaznaczenie do początku wiersza
CTRL+SHIFT+HOME
Rozszerza zaznaczenie do początku arkusza
CTRL+SHIFT+END
Rozszerza zaznaczenie do ostatniej użytej komórki w arkuszu (dolny prawy róg)
CTRL+SPACJA
Zaznacza całą kolumnę
SHIFT+SPACJA
Zaznacza cały wiersz
CTRL+A
Zaznacza cały wiersz
SHIFT+PAGE UP
Rozszerza zaznaczenie o jeden ekran w górę

Klawisze do pracy z listami rozwijanymi Autofiltru

CTRL+T
Włącza autofiltrowanie w zaznaczonym zakresie
ALT+STRZAŁKA W DÓŁ
Otwiera listę rozwijaną Autofiltru dla zaznaczonej komórki
Klawisz TAB
Przenosi kolejno do niedawno wybranego elementu, przycisku OK i przycisku Anuluj na liście rozwijanej Autofiltru
Klawisze strzałek
Przenosi do następnego lub poprzedniego elementu na liście rozwijanej Autofiltru
Klawisze liter i cyfr
Przenoszą do pierwszego elementu rozpoczynającego się od danej litery lub cyfry na liście rozwijanej Autofiltru
SHIFT+ klawisze strzałek
Rozszerza zaznaczenie na liście rozwijanej Autofiltru
SPACJA
Powoduje zaznaczenie lub wyczyszczenie pól wyboru dla wybranych elementów listy rozwijanej Autofiltru
ENTER
Powoduje zamknięcie listy rozwijanej Autofiltru i zastosowanie wprowadzonych zmian
ESC
Powoduje zamknięcie listy rozwijanej Autofiltru bez zastosowania zmian

Klawisze do pracy z Pomocą

Klawisze do pracy w oknie Pomocy

F6
Przełącza między okienkiem nawigacji i okienkiem tematu
ALT+O
Wyświetla menu Opcje, aby udostępnić każde polecenie na pasku narzędzi Pomoc
ALT+SPACJA
Wyświetla menu Sterowanie programu
ALT+F4
Zamyka okno Pomocy

Klawisze do pracy w okienku nawigacji

CTRL+TAB
Przełącza do innej karty
ENTER
Otwiera lub zamyka zaznaczoną książkę albo otwiera zaznaczony temat Pomocy
STRZAŁKA W DÓŁ
Zaznacza następną książkę lub temat Pomocy
STRZAŁKA W GÓRĘ
Zaznacza poprzednią książkę lub temat Pomocy
SHIFT+F10
Wyświetla menu skrótów

Klawisze do pracy w okienku tematu

ALT+STRZAŁKA W PRAWO
Przechodzi dalej do poprzednio przeglądanego tematu Pomocy
ALT+STRZAŁKA W LEWO
Przechodzi wstecz do poprzednio przeglądanego tematu Pomocy
Klawisz TAB
Zaznacza następny tekst ukryty lub hiperłącze albo przycisk Pokaż wszystko lub Ukryj wszystko na początku tematu
SHIFT+TAB
Zaznacza poprzedni tekst ukryty lub hiperłącze
ENTER
Powoduje wykonanie akcji zaznaczonego przycisku Pokaż wszystko, Ukryj wszystko, tekstu ukrytego lub hiperłącza
STRZAŁKA W GÓRĘ albo STRZAŁKA W DÓŁ
Przewija w kierunku początku albo końca tematu Pomocy
PGUP lub PGDN
Przewija w kierunku początku albo końca tematu Pomocy w większych przyrostach
HOME albo END
Przechodzi do początku albo końca tematu Pomocy
CTRL+P
Drukuje bieżący temat Pomocy
CTRL+A
Zaznacza cały temat Pomocy
CTRL+C
Kopiuje zaznaczenie do Schowka
SHIFT+F10
Wyświetla menu skrótów


Narzędzia, polecenia i opcje arkusza kalkulacyjnego — informacje

Pasek narzędzi

Znajdujący się u góry arkusza kalkulacyjnego pasek narzędzi zawiera zestaw poleceń umożliwiających pracę z danymi arkusza kalkulacyjnego. Paska narzędzi można używać w trakcie projektowania arkusza kalkulacyjnego; mogą go również wykorzystywać użytkownicy przeglądarki do pracy z arkuszem kalkulacyjnym. Aby zobaczyć odpowiadającą przyciskowi nazwę polecenia, należy umieścić wskaźnik myszy na przycisku.

Okno dialogowe Polecenia i opcje

Okno dialogowe Polecenia i opcje zawiera polecenia umożliwiające znajdowanie danych w arkuszu kalkulacyjnym, na przykład Znajdź następny, oraz właściwości, które można ustawiać, na przykład kolor tła komórek oraz szerokość kolumn. To okno dialogowe zawiera również pewne polecenia, których nie ma na pasku narzędzi lub w menu skrótów. Aby wyświetlić to okno dialogowe, należy kliknąć przycisk Polecenia i opcje [image] na pasku narzędzi.

Polecenia i właściwości znajdujące się w oknie dialogowym Polecenia i opcje są rozmieszczone na kilku kartach, takich jak karta Formuła, na której można zobaczyć formułę w zaznaczonej komórce lub zdefiniować nazwy używane w formułach, czy karta Format, na której można ustawiać formaty liczby, zmieniać kolor tekstu, wybierać style obramowania i inne.

Niektóre właściwości i polecenia są dostępne zarówno podczas projektowania arkusza kalkulacyjnego, jak i po wyświetleniu go w przeglądarce. Inne są dostępne tylko podczas pracy w programie projektowym.

Ograniczanie dostępu do paska narzędzi i okna dialogowego Polecenia i opcje

Jeżeli użytkownicy nie mają mieć dostępu do okna dialogowego Polecenia i opcje w przeglądarce, można włączyć ochronę arkusza kalkulacyjnego, aby to okno dialogowe było niedostępne.

Jeżeli użytkownicy nie mają mieć dostępu do paska narzędzi w przeglądarce, można ukryć pasek narzędzi. Aby upewnić się, że użytkownicy nie mogą wyświetlić go ponownie, należy także zablokować dostęp do okna dialogowego Polecenia i opcje, ponieważ znajduje się w nim polecenie umożliwiające ponowne wyświetlenie paska narzędzi.


Wyświetlanie lub ukrywanie paska narzędzi arkusza kalkulacyjnego

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Kliknij prawym przyciskiem myszy komórkę w arkuszu kalkulacyjnym, kliknij polecenie Polecenia i opcje w menu skrótów, a następnie kliknij kartę Skoroszyt.
  3. W obszarze Pokazywanie/Ukrywanie zaznacz albo wyczyść pole wyboru Pasek narzędzi.


Pokazywanie lub ukrywanie okna dialogowego Polecenia i opcje

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Wykonaj jedną z następujących czynności:
    • Aby pokazać okno dialogowe Polecenia i opcje, kliknij przycisk Polecenia i opcje [image] na pasku narzędzi.
    • Aby ukryć okno dialogowe Polecenia i opcje kliknij przycisk Zamknij Zamknij znajdujący się w prawym górnym rogu okna dialogowego.


Tworzenie składnika Arkusz kalkulacyjny pakietu Microsoft Office

Określone kroki umożliwiające utworzenie arkusza kalkulacyjnego zależą od programu używanego do projektowania strony sieci Web. Więcej informacji można znaleźć w Pomocy używanego programu. Jeśli Pomoc programu projektowego nie opisuje procedury tworzenia takich składników, jak arkusze kalkulacyjne, wykonaj następujące kroki:

  1. W programie projektowym otwórz lub utwórz stronę sieci Web, na której ma pojawiać się arkusz kalkulacyjny.
  2. Używając procedury programu projektowego służącej do dodawania składnika do strony sieci Web, wybierz składnik arkusz kalkulacyjny i wyznacz jego lokalizację i początkowy rozmiar na stronie sieci Web.
  3. Wprowadź dane i formuły w arkuszu kalkulacyjnym lub importuj dane, które mają być użyte w arkuszu kalkulacyjnym.
  4. Użyj okna dialogowego Polecenia i opcje i paska narzędzi do dostosowania arkusza kalkulacyjnego.
  5. Korzystając z instrukcji zawartych w programie projektowym, opublikuj arkusz kalkulacyjny.


Dodawanie lub usuwanie arkuszy

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Kliknij przycisk Polecenia i opcje [image] na pasku narzędzi, a następnie kliknij kartę Skoroszyt.
  3. W obszarze Arkusze wykonaj jedną z następujących czynności:
    • Aby dodać arkusz, kliknij przycisk Wstaw. Powtórz tę operację, aby dodać kilka arkuszy.

      Możesz zmienić nazwę wstawianego arkusza, zaznaczając ją na liście Nazwa arkusza, wpisując nową nazwę w polu Nazwa arkusza i naciskając klawisz ENTER.

    • Aby usunąć arkusz, kliknij jego nazwę na liście Nazwa arkusza, a następnie kliknij przycisk Usuń.

      Arkusz i znajdujące się w nim dane zostaną trwale usunięte.


Zmiana nazwy arkusza

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Skoroszyt.
  3. W obszarze Arkusze, na liście Nazwa arkusza kliknij nazwę arkusza, którą chcesz zmienić.
  4. Wpisz nową nazwę w polu Nazwa arkusza.
  5. Naciśnij klawisz ENTER.


Zmiana kolejności arkuszy

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Skoroszyt.
  3. W obszarze Arkusze, na liście Nazwa arkusza kliknij nazwę arkusza, który chcesz przenieść.
  4. Kliknij przycisk W górę [image] , aby przenieść arkusz w kierunku początku skoroszytu albo kliknij przycisk W dół [image] , aby przenieść arkusz w kierunku końca skoroszytu.


Wyświetlanie lub ukrywanie nagłówków kolumn lub nagłówków wierszy

Nagłówki kolumn to litery w komórkach o kolorze szarym (lub innym, w zależności od ustawień ekranu systemu Microsoft Windows), znajdujących się u góry arkusza kalkulacyjnego, a nagłówki wierszy to liczby w komórkach o kolorze szarym, biegnących z boku arkusza kalkulacyjnego.

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Arkusz.
  3. W obszarze Pokazywanie/Ukrywanie zaznacz albo wyczyść pola wyboru Nagłówki kolumn lub Nagłówki wierszy.


Wyświetlanie lub ukrywanie linii siatki w arkuszu kalkulacyjnym

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Arkusz.
  3. W obszarze Pokazywanie/Ukrywanie zaznacz albo wyczyść pole wyboru Linie siatki.


Pokazywanie lub ukrywanie selektora arkuszy

Selektor arkuszy składa się z karty Nazwa arkusza oraz listy Arkusz, która pojawia się po kliknięciu strzałki znajdującej się na karcie.

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Skoroszyt.
  3. W obszarze Pokazywanie/Ukrywanie zaznacz lub wyczyść pole wyboru Selektor arkuszy.


Pokazywanie lub ukrywanie pasków przewijania

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Skoroszyt.
  3. W obszarze Pokazywanie/Ukrywanie zaznacz lub wyczyść pola wyboru Pasek przewijania poziomego i Pasek przewijania pionowego.


Pokazywanie lub ukrywanie arkuszy

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Skoroszyt.
  3. W obszarze Arkusze, na liście Nazwa arkusza zaznacz nazwę arkusza, który chcesz pokazać lub ukryć.
  4. Kliknij przycisk Ukryj lub Odkryj.

Uwaga Przycisk Odkryj jest dostępny tylko w przypadku arkuszy ukrytych. Nazwy arkuszy ukrytych są identyfikowane przez wyraz „(ukryty)”.


Pokazywanie tylko części arkusza kalkulacyjnego

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Arkusz.
  3. W polu Widoczny zakres wpisz zakres, który powinien być wyświetlany.

    Na przykład, aby wyświetlić wiersze od 1. do 15., wpisz 1:15. Aby wyświetlić kolumny od A do F, wpisz A:F. Aby wyświetlić komórki od A1 do B20, wpisz A1:B20.

Uwaga Tego ustawienia nie można zmienić w przeglądarce.


Zmiana komórki, która staje się aktywna po naciśnięciu klawisza ENTER

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Zaawansowane.
  3. Aby przenieść zaznaczenie aktywnej komórki lub uniknąć przenoszenia zaznaczenia aktywnej komórki po naciśnięciu klawisza ENTER, zaznacz lub wyczyść pole wyboru Przenieś po powrocie.

    Chcąc określić kierunek, w którym ma być przenoszone zaznaczenie aktywnej komórki po naciśnięciu klawisza ENTER, kliknij strzałkę znajdującą się obok pola Kierunek przenoszenia, a następnie kliknij pozycję W dół, Do lewej, Do prawej albo W górę.

Uwaga Zaznaczenie komórki nie zostanie przesunięte, jeśli osiągnięto granicę arkusza kalkulacyjnego. Na przykład, jeśli zaznaczenie komórki zostało ustawione na przechodzenie w dół i w ostatnim wierszu naciśnięto klawisz ENTER, to zaznaczenie nie zostanie przesunięte.


Zachowywanie widocznych wierszy lub kolumn podczas przewijania arkusza kalkulacyjnego

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Zaznacz wiersz znajdujący się poniżej wierszy, które mają być widoczne podczas przewijania lub zaznacz kolumnę znajdującą się po prawej stronie kolumn, które mają być widoczne.

    Aby podczas przewijania widoczne były zarówno określone wiersze, jak i kolumny, zaznacz komórkę znajdującą się poniżej wierszy i po prawej stronie kolumn, które mają być widoczne.

  3. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Arkusz.
  4. Kliknij przycisk Zablokuj okienka [image] .

Uwaga Tego ustawienia nie można zmienić w przeglądarce.


Wyłączanie i włączanie automatycznej zmiany rozmiaru arkusza kalkulacyjnego

Po ustawieniu arkusza kalkulacyjnego na rozmiar wyświetlanego zakresu i włączeniu opcji automatycznej zmiany rozmiaru, arkusz kalkulacyjny jest powiększany lub pomniejszany na stronie sieci Web w zależności od treści. Rozmiar arkusza kalkulacyjnego zmienia się w miarę wstawiania lub usuwania wierszy i kolumn albo w przypadku zmiany wysokości wierszy lub szerokości kolumn.

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Zaawansowane.
  3. Zaznacz lub wyczyść pole wyboru Autodopasowanie arkusza kalkulacyjnego.

    Aby ograniczyć powiększanie arkusza kalkulacyjnego do określonego rozmiaru, wpisz wartość — w pikselach lub procentowo w odniesieniu do całej strony sieci Web — w jednym lub obu polach Maksymalna wysokość i Maksymalna szerokość. Na przykład, aby zezwolić na powiększanie arkusza do połowy szerokości strony sieci Web, wpisz wartość 50 % w polu Maksymalna szerokość. Aby ograniczyć szerokość arkusza do 300 pikseli, wpisz wartość 300 w polu Maksymalna szerokość.


Tworzenie wykresu na podstawie arkusza kalkulacyjnego

Jeśli arkusz kalkulacyjny jest publikowany z programu Microsoft Excel, to można wykorzystać dostępne w tym programie rozbudowane możliwości tworzenia wykresów, aby utworzyć wykres na podstawie danych z arkusza kalkulacyjnego i opublikować wykres razem z arkuszem kalkulacyjnym. Jest to jeden z najprostszych sposobów tworzenia wykresu na podstawie arkusza kalkulacyjnego.

W innych programach do projektowania można utworzyć arkusz kalkulacyjny i wykres za pomocą dwóch składników Microsoft Office Web Components: Arkusza kalkulacyjnego i Wykresu.

Aby utworzyć wykres dla arkusza kalkulacyjnego, wykonaj następujące kroki.

  1. Postępując według wskazówek wyświetlanych w programie do projektowania, skorzystaj ze składnika Arkusz kalkulacyjny, aby utworzyć na stronie sieci Web arkusz kalkulacyjny zawierający dane, które chcesz przedstawić na wykresie.
  2. Postępując według wskazówek wyświetlanych w programie do projektowania, skorzystaj ze składnika Wykres, aby utworzyć wykres na tej stronie sieci Web, na której znajduje się arkusz kalkulacyjny.
  3. Jeśli nie pojawiło się okno dialogowe Polecenia i opcje, kliknij wykres.
  4. Na karcie Źródło danych, w obszarze Wybierz skąd pochodzą dane wykresu kliknij opcje Dane z następującego elementu strony sieci Web.
  5. Kliknij element arkusza kalkulacyjnego dostępny na liście.
  6. W obszarze Określ szczegóły typu danych kliknij opcje Zakresy.
  7. Wykonaj jedna z następujących czynności:

    Określ wszystkie dane jednocześnie

    1. W obszarze Ustaw zakresów w jednym kroku wprowadź odwołanie do zakresu danych, dla których chcesz utworzyć wykres, oddzielając komórki w polu Zakres danych za pomocą dwukropka (:). Na przykład jeśli potrzebne dane znajdują się w arkuszu kalkulacyjnym w zakresie ciągłym obejmującym komórki od A1 do G5, to w polu Zakres danych wpisz A1:G5.

    2. Kliknij przycisk OK.

    3. Kliknij opcje Wiersze lub Kolumny znajdująca się obok pola Serie w, aby określić lokalizacje danych serii.

    Określ kolejne serie danych

    1. W obszarze Serie kliknij przycisk Dodaj.

    2. Aby nadąć serii nazwę opisowa, w polu Nazwa serii zastąp domyślną nazwę serii własną nazwą.

    3. W polu Etykiety kategorii wpisz odwołania do komórek zawierających etykiety kategorii danej serii. Na przykład, jeśli dodawana seria znajduje się w zakresie komórek od A2 do G2, a etykiety kategorii znajdują się w zakresie komórek od A1 do G1, wpisz A1:G1.

    4. W polu Wartości wpisz odwołanie do zakresu wartości dla danej serii. Na przykład jeśli seria danych znajduje się w arkuszu kalkulacyjnym w komórkach od A2 do G2, wpisz A2:G2.

    5. Powtórz poprzedni krok w przypadku każdej serii danych, która chcesz dodać.

  8. Kliknij kartę Typ, a następnie wybierz zadany typ wykresu.

Uwaga Aby uzyskać Pomoc dotyczącą poleceń związanych z wykresem oraz takich opcji, jak formatowanie i modyfikowanie wykresu, na karcie Format w oknie dialogowym Polecenia i opcje wykresu kliknij przycisk Pomoc [image].


Zapisywanie zmian

Aby zapisać zmiany, należy wykorzystać polecenie programu projektowego służące do zapisywania strony sieci Web lub pliku zawierającego arkusz kalkulacyjny. Informacje o sposobie zapisywania strony sieci Web lub pliku można znaleźć w Pomocy programu projektowego.

Uwagi

  • Jeśli arkusz kalkulacyjny opublikowano z arkusza programu Microsoft Excel, a następnie otwarto stronę sieci Web w innym programie projektowym, to zapisanie strony sieci Web nie spowoduje zapisania zmian w oryginalnym arkuszu programu Excel.
  • Chcąc zapisać kopię arkusza kalkulacyjnego jako arkusz programu Excel, można wyeksportować arkusz kalkulacyjny do programu Excel, klikając przycisk Eksportuj do programu Microsoft Excel Eksportuj do programu Excel na pasku narzędzi. Można także skopiować dane z arkusza kalkulacyjnego do programu Excel lub innych programów.
  • Użytkownicy nie mogą zapisać strony sieci Web w przeglądarce, ale mogą wyeksportować lub skopiować ją z przeglądarki.


Cofanie zmian

  • Aby cofnąć ostatnią zmianę wprowadzoną w arkuszu kalkulacyjnym, kliknij przycisk Cofnij [image] na pasku narzędzi. Można cofać wiele zmian (do 16), klikając kilkakrotnie przycisk Cofnij [image].
  • Aby cofnąć wszystkie zmiany wprowadzone w arkuszu kalkulacyjnym od momentu ostatniego zapisu strony sieci Web, zamknij stronę sieci Web bez zapisywania jej w programie projektowym.


Drukowanie arkusza kalkulacyjnego

Aby wydrukować arkusz kalkulacyjny ze strony sieci Web, wydrukuj całą stronę sieci Web.

  • Aby wydrukować arkusz kalkulacyjny z okna projektu, zobacz Pomoc programu projektowego w celu znalezienia specyficznych instrukcji na temat drukowania strony sieci Web.

  • Aby wydrukować arkusz kalkulacyjny z przeglądarki, kliknij polecenie Drukuj w menu Plik programu Microsoft Internet Explorer.

Uwaga Jeśli arkusz kalkulacyjny jest szerszy lub dłuższy niż drukowana strona, to obszary niemieszczące się na stronie nie zostaną wydrukowane. Aby lepiej kontrolować sposób drukowania danych oraz mieć możliwość drukowania długich list i ustawiania podziałów stron, można wyeksportować arkusz kalkulacyjny do programu Microsoft Excel, klikając przycisk Eksportuj do programu Microsoft Excel Eksportuj do programu Microsoft Excel na pasku narzędzi. Informacje na temat drukowania z programu Excel można znaleźć w Pomocy programu Excel.


Usuwanie ochrony arkusza kalkulacyjnego

Tę procedurę można wykonać tylko w czasie projektowania. Użytkownicy nie mają dostępu do tej opcji w przeglądarce.

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Ochrona.
  3. W obszarze Arkusz wyczyść pole wyboru Chroń aktywny arkusz.
  4. Aby użytkownicy mogli wstawiać i usuwać arkusze oraz zmieniać ich nazwy lub używać okna dialogowego Polecenia i opcje, sprawdź, czy w obszarze Skoroszyt zaznaczone są pola wyboru Wstawianie, usuwanie lub zmiana nazw arkuszy oraz Okno dialogowe Polecenia i opcje.


Ograniczanie użycia arkusza kalkulacyjnego w przeglądarce

Można zapobiec wprowadzaniu przez użytkowników zmian w arkuszach, używając opcji ochrony dostępnych jedynie w czasie projektowania. Obowiązują one podczas działania i w zasadzie nie są stosowane w czasie projektowania arkusza kalkulacyjnego.

Ochrona całego arkusza

Poszczególne arkusze można chronić niezależnie. Jeśli arkusz jest chroniony, użytkownicy nie mogą modyfikować komórek; wstawiać i usuwać wierszy lub kolumn ani zmieniać ich rozmiaru; filtrować lub sortować zawartości arkusza, chyba że zostaną włączone umożliwiające to opcje.

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Ochrona.
  3. Wybierz pole wyboru Chroń aktywny arkusz.

    Aby umożliwić użytkownikom wprowadzanie pewnych zmian w arkuszu, na przykład zmianę rozmiaru, sortowanie lub filtrowanie, zaznacz odpowiadające tym opcjom pola wyboru w obszarze W czasie działania zezwalaj na.

Ochrona tylko określonych komórek

Jeśli arkusz jest chroniony, to wszystkie komórki arkusza są zablokowane, chyba że niektóre z nich zostaną odblokowane.

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Zaznacz komórki, które można zmieniać po włączeniu ochrony arkusza kalkulacyjnego.
  3. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Format.
  4. Kliknij przycisk Odblokuj komórki [image].
  5. Powtórz poprzednie kroki, aby określić inne komórki, które można zmieniać po włączeniu ochrony arkusza kalkulacyjnego.
  6. Kliknij kartę Ochrona.
  7. Zaznacz pole wyboru Chroń aktywny arkusz.

Wyświetlanie jedynie części arkusza kalkulacyjnego

Można ukryć część arkusza kalkulacyjnego przed wyświetlaniem. Użytkownicy nie mają dostępu do ukrytej części.

Jak?

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Arkusz.
  3. W polu Widoczny zakres wpisz zakres, który powinien być wyświetlany.

    Na przykład, aby wyświetlić wiersze od 1. do 15., wpisz 1:15. Aby wyświetlić kolumny od A do F, wpisz A:F. Aby wyświetlić komórki od A1 do B20, wpisz A1:B20.

Uwaga Tego ustawienia nie można zmienić w przeglądarce.

Uniemożliwienie wstawiania, usuwania lub zmiany nazw arkuszy

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Ochrona.
  3. W obszarze Skoroszyt wyczyść pole wyboru Wstawianie, usuwanie lub zmiana nazw arkuszy.

Uniemożliwienie wyświetlania okna dialogowego Polecenia i opcje

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Ochrona.
  3. W obszarze Skoroszyt wyczyść pole wyboru Okno dialogowe Polecenia i opcje.

Uniemożliwianie monitorowania zdarzeń przez programy i skrypty lub zezwalanie na nie

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Zaawansowane.
  3. Zaznacz lub wyczyść pole wyboru Włącz zdarzenia.

Uwagi

  • Nie można ustawić haseł dla arkuszy kalkulacyjnych.
  • Jeśli użytkownicy nie powinni mieć możliwości wprowadzania zmian w arkuszu kalkulacyjnym, można rozważyć opublikowanie nieinterakcyjnej wersji HTML arkusza kalkulacyjnego. Więcej informacji można znaleźć w Pomocy programu Microsoft Excel.


Sposób interpretowania przez arkusz kalkulacyjny dat związanych z rokiem 2000 i późniejszych

Ze względu na złożoność reguł określających sposób interpretowania dat przez dowolny program obliczeniowy, daty należy wprowadzać, dążąc do podania jak najdokładniejszych informacji. Pozwoli to osiągnąć najwyższy poziom dokładności w obliczeniach.

Sposób interpretowania niejednoznacznych dat przez arkusz kalkulacyjny Interpretując niejednoznaczne daty, arkusz kalkulacyjny przyjmuje pewne założenia. Na przykład po wprowadzeniu daty zawierającej tylko nazwę miesiąca i jedną lub dwie cyfry, arkusz kalkulacyjny zakłada, że cyfry od 1 do 31 oznaczają dzień, a jako rok przyjmuje rok bieżący. Na przykład zapis grudzień 01 zostanie zinterpretowany jako pierwszy grudnia bieżącego roku, a nie grudzień 2001 r. Zapis grudzień 32 zostanie zinterpretowany jako pierwszy grudnia 1932 roku.

Sposób interpretowania dwucyfrowych numerów lat przez arkusz kalkulacyjny Wprowadzona dwucyfrowa wartość roku domyślnie jest interpretowana przez arkusz w następujący sposób:

  • Od 00 do 29 Arkusz kalkulacyjny interpretuje wartości dwucyfrowe od 00 do 29 jako lata od 2000 do 2029. Na przykład po wpisaniu daty 19-05-28 arkusz przyjmuje, że jest to data 28 maja 2019 r.
  • Od 30 do 99 Arkusz interpretuje wartości dwucyfrowe od 30 do 99 jako lata od 1930 do 1999. Na przykład po wpisaniu daty 98-05-28 arkusz przyjmuje, że jest to data 28 maja 1998 r.

Użycie czterocyfrowego roku Aby zapewnić prawidłowy sposób interpretowania przez arkusz kalkulacyjny wartości oznaczających rok, zgodnie z zamiarem użytkownika, należy wpisać wartości roku jako liczbę czterocyfrową (na przykład 2001 zamiast 01).

Jeśli systemy użytkowników są dostosowane w inny sposób niż system lokalny, to daty wprowadzane przez użytkowników w przeglądarce mogą być interpretowane inaczej niż daty wprowadzane w programie projektowym. Aby zapewnić prawidłową interpretację dat w przeglądarce, należy wprowadzać wszystkie daty z czterocyfrowym numerem roku.

Zmiana sposobu interpretacji numeru roku Administrator systemu lokalnego lub administrator systemu użytkowników może dostosować pakiet Microsoft Office, aby przy interpretacji dat były stosowane różne reguły. Na przykład administrator może zmienić pierwszy dwucyfrowy numer roku interpretowany jako data w dwudziestym wieku i zamiast numeru 30 wybrać inny numer. Ponadto administratorzy mogą tak zmieniać domyślny format daty, aby do oznaczenia roku służyły wartości czterocyfrowe, a nie dwucyfrowe.

Aby ustalić, czy używany system stosuje niestandardową interpretację daty, skontaktuj się z administratorem systemu. Aby uzyskać informacje dotyczące dostosowywania interpretacji dat, zobacz zestaw Microsoft Office XP Resource Kit.


Wprowadzanie tekstu, liczb, dat i godzin w arkuszu kalkulacyjnym — informacje

Wprowadzanie tekstu

Znaki traktowane jako tekst W przypadku arkusza kalkulacyjnego za tekst uważana jest dowolna kombinacja liczb, spacji i znaków nienumerycznych — na przykład arkusz kalkulacyjny traktuje następujące wpisy jako tekst:

10AA109, 127AXY, 12-976, 208 4675

Wprowadzanie liczb i dat jako tekstu Aby tak wprowadzić liczby i daty, aby były przechowywane jako tekst, należy wpisać apostrof (') na początku tekstu. Na przykład, aby wprowadzić numer 02-01-23 jako tekst, a nie datę, należy wpisać '02-01-23.

Wyrównanie tekstu Tekst jest domyślnie wyrównany w komórce do lewej. Można zmienić to ustawienie, aby tekst był wyrównywany do środka lub do prawej.

Tekst nie może być zawijany w komórkach W jednej komórce nie można wyświetlać wielu wierszy tekstu.

Powtarzający się tekst Aby wprowadzić ten sam ciąg tekstowy do wielu komórek, należy zaznaczyć te komórki, wpisać tekst, a następnie nacisnąć klawisze CTRL+ENTER.

Symbol waluty euro Aby wprowadzić symbol euro ( [image]), należy upewnić się, czy włączony jest klawisz NUM LOCK, a następnie wpisać na klawiaturze numerycznej kombinację ALT+0128. Jeśli używany jest system operacyjny Microsoft Windows 95 lub Microsoft Windows NT 4.0 z pakietem Service Pack 3 lub starszym, konieczna może być instalacja aktualizacji euro z witryny firmy Microsoft w sieci Web. Aby uzyskać informacje na temat łączenia się z witryną Microsoft Web, zobacz Pomoc programu projektowego. Symbol euro można wyświetlić za pomocą następujących czcionek.

System operacyjny | Czcionki
Microsoft Windows 2000 | Arial, Courier New, Tahoma (zwykła i pogrubiona), Times New Roman
Microsoft Windows 98 | Arial, Courier New, Tahoma (zwykła i pogrubiona), Times New Roman
Microsoft Windows 95 z aktualizacją euro | Arial Black, Arial, Comic Sans (zwykła i pogrubiona), Courier New, Impact, MS Sans Serif, Tahoma (zwykła i pogrubiona), Times New Roman, Verdana
Microsoft Windows NT 4.0 z pakietem Service Pack 3 lub starszym i aktualizacją euro | Arial, Courier New, Times New Roman
Microsoft Windows NT 4.0 z pakietem Service Pack 4 | Arial, Courier New, Lucida Console, Lucida Sans Unicode, Times New Roman

Wprowadzanie liczb

Znaki, które mogą być użyte jako liczby W przypadku arkusza kalkulacyjnego liczba może się składać jedynie z następujących znaków:

0 1 2 3 4 5 6 7 8 9 + – ( ) , / $ % . E e

Arkusz kalkulacyjny ignoruje początkowe znaki plus (+) i traktuje pojedyncze przecinki (,) w ciągu numerycznym jako separatory w liczbach dziesiętnych. Wszystkie ciągi zawierające liczby i znaki nienumeryczne są traktowane jako tekst.

Wprowadzanie ułamków Aby uniknąć wprowadzenia ułamka jako daty, należy poprzedzić go cyfrą 0 (zero) i spacją; na przykład 0 1/2.

Wprowadzanie liczb ujemnych Liczby ujemne należy poprzedzać znakiem minus (–) lub wpisywać w nawiasach okrągłych ( ).

Wyrównywanie liczb Wszystkie liczby w komórkach są domyślnie wyrównywane do prawej. Można zmienić to ustawienie, aby liczby były wyrównywane do środka lub do lewej.

Wyświetlanie liczb Zastosowany w przypadku danej komórki format liczby określa sposób wyświetlania liczby. Jeśli liczba zostanie wpisana do komórki o ogólnym formacie liczby, to arkusz kalkulacyjny może zastosować inny format liczby. Na przykład, jeśli wpisano wartość 14,73 zł, to arkusz kalkulacyjny zastosuje format walutowy. Format liczby można zmieniać.

Ogólny format liczby W komórkach o ogólnym formacie liczby arkusz kalkulacyjny wyświetla liczby jako całkowite (789), ułamki dziesiętne (7,89) lub w notacji naukowej (7,89E+08). Notacja naukowa jest używana automatycznie, jeśli długość liczby przekracza szerokość komórki. W ogólnym formacie liczby może być wyświetlonych maksymalnie 11 cyfr, łącznie z przecinkiem dziesiętnym i takimi znakami, jak „E” i „+”. Aby użyć liczb składających się z więcej niż 11 cyfr, można zastosować naukowy format liczby (notacja wykładnicza).

Limit 15 cyfr Niezależnie od liczby wyświetlanych cyfr, arkusz kalkulacyjny przechowuje liczby z dokładnością do 15 cyfr. Jeśli liczba składa się z więcej niż 15 cyfr znaczących, to arkusz kalkulacyjny konwertuje nadmiarowe cyfry na zera (0).

Ustawienia regionalne Rozpoznawanie znaków jako liczb zależy od opcji wybranych w ustawieniach regionalnych w Panelu sterowania systemu Microsoft Windows. Wybrane opcje określają także domyślny format liczb — na przykład kropka (.) jest używana jako symbol dziesiętny w systemach opartych na języku angielskim (USA). Jeśli użytkownicy mają w swoich systemach ustawienia regionalne różniące się od ustawień używanych podczas tworzenia arkusza kalkulacyjnego, to liczby w przeglądarce mogą być wyświetlane inaczej.

Powtarzające się dane Aby wprowadzić te same dane do wielu komórek, należy zaznaczyć te komórki, wpisać dane, a następnie nacisnąć klawisze CTRL+ENTER.

Wprowadzanie dat i godzin

Daty i godziny są liczbami Arkusz kalkulacyjny traktuje daty i godziny jako liczby. Sposób wyświetlania w komórce godziny lub daty zależy od formatu liczby zastosowanego w przypadku tej komórki. Po wpisaniu daty lub godziny, którą rozpoznaje arkusz kalkulacyjny, format komórki zmieni się z ogólnego formatu liczby na na format daty lub godziny. Domyślnie, daty i godziny są wyrównywane w komórce do prawej. Jeśli arkusz kalkulacyjny nie rozpoznaje formatu daty lub godziny, to zostaną one wprowadzone jako tekst, który będzie wyrównany w komórce do lewej.

Panel sterowania Opcje wybrane w ustawieniach regionalnych w Panelu sterowania systemu Microsoft Windows określają domyślny format bieżącej daty i godziny oraz znaki rozpoznawane jako separatory dat i godzin — na przykład kreskę ułamkową (/) i łącznik (–) dla dat i dwukropek (:) dla godzin w systemach opartych na języku angielskim (USA). Jeśli użytkownicy mają w swoich systemach ustawienia regionalne różniące się od ustawień używanych podczas tworzenia arkusza kalkulacyjnego, to w przeglądarce inne znaki mogą być rozpoznawane jako znaki separatora.

Użycie czterocyfrowego numeru roku Interpretując niejednoznaczne daty, arkusz kalkulacyjny przyjmuje pewne założenia. Na przykład po wprowadzeniu daty zawierającej tylko nazwę miesiąca i jedną lub dwie cyfry, arkusz kalkulacyjny zakłada, że liczby od 1 do 31 określają dzień, a za rok przyjmuje bieżący rok. Na przykład, zapis grudzień 01 zostanie zinterpretowany jako 1 grudnia bieżącego roku, a nie jako grudzień 2001 roku. Zapis grudzień 32 zostanie odczytany jako 1 grudnia 1932 roku. Zapis 12/1/30 zostanie odczytany jako 1 grudnia 1930 roku, ale zapis 12/1/29 oznacza 1 grudnia 2029 roku, jeżeli administrator systemu nie zmienił domyślnej metody odczytywania krótkich dat.

Aby mieć pewność, że daty będą interpretowane przez arkusz kalkulacyjny zgodnie z oczekiwaniami, należy zawsze wpisywać cztery cyfry oznaczające rok.

Jednoczesne wprowadzanie dat i godzin Aby wprowadzić datę i godzinę w tej samej komórce, pomiędzy datą i godziną należy wpisać spację — na przykład 7/10/1976 23:12.

Wprowadzanie godzin z symbolem AM lub PM Aby wprowadzić godzinę w formacie 12-godzinnym, należy wpisać godzinę, a następnie spację i symbol AM lub PM — na przykład 9:00 oraz symbol AM lub PM.

Wyświetlanie liczby kolejnej odpowiadającej dacie lub godzinie Niezależnie od formatu użytego do wyświetlania daty lub godziny, w arkuszu kalkulacyjnym wszystkie daty są przechowywane jako kolejne liczby, a godziny jako ułamki dziesiętne. Aby wyświetlić datę jako kolejną liczbę lub godzinę jako ułamek, należy zaznaczyć komórki zawierające daty lub godziny i zmienić format liczby na ogólny format liczby. W ogólnym formacie liczby część liczby odpowiadająca dacie znajduje się po lewej stronie, a część odpowiadająca godzinie po prawej stronie przecinka dziesiętnego. W arkuszu kalkulacyjnym liczba kolejna daty równa 1 odpowiada dacie niedziela, 31 grudnia 1899.

Obliczenia wykorzystujące daty i godziny Daty i godziny można dodawać, odejmować i stosować w innych obliczeniach. Aby użyć daty lub godziny w formule, należy wprowadzić datę lub godzinę jako tekst umieszczony w cudzysłowie. Na przykład, wynik następującej formuły zostanie wyświetlony jako 68:

="5/12/2004"-"3/5/2004"


Wprowadzanie tekstu, liczb, dat i godzin do arkusza kalkulacyjnego

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Kliknij komórkę, do której chcesz wprowadzić dane.
  3. Wpisz dane, a następnie naciśnij klawisz ENTER lub TAB.

Uwagi

  • Do rozdzielenia poszczególnych części daty należy użyć kreski ułamkowej lub łącznika; na przykład 5/9/2002 lub 5-Wrz-2002.

  • Aby wprowadzić godzinę na podstawie zegara 12-godzinnego, należy wpisać godzinę, a następnie spację i symbol AM lub PM; na przykład 9:00 PM. W przeciwnym wypadku do arkusza zostanie wprowadzona godzina jako AM (przed południem).

  • Formuły należy poprzedzić znakiem równości (=).

  • Aby wprowadzić hiperłącze, należy wpisać adres URL rozpoczynający się od identyfikatora protokołu, na przykład http:// lub ftp://, a następnie nacisnąć klawisz ENTER.

  • Aby wprowadzić te same dane do wielu komórek, należy zaznaczyć te komórki, wpisać dane, a następnie nacisnąć klawisze CTRL+ENTER.


Zmiana danych w komórce

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Kliknij komórkę, którą chcesz zmienić.
  3. Wykonaj jedną z następujących czynności:

    • Aby wprowadzić nową liczbę lub tekst w komórce, zamieniając bieżącą zawartość komórki, wpisz nową wartość.

    • Aby zmienić część zawartości komórki, kliknij dwukrotnie komórkę i dokonaj zmian.

  4. Aby zaakceptować zmiany w komórce, naciśnij klawisz ENTER.

Uwagi

  • Komórka może mieć tylko jedną czcionkę i format tekstu.
  • Po wyświetleniu komunikatu wskazującego, że zakres jest zablokowany, należy wyłączyć ochronę, aby umożliwić modyfikowanie komórki.


Przenoszenie i kopiowanie danych — informacje

Podczas kopiowania komórek kopiowana jest cała komórka, łącznie z formułami i ich wynikami oraz formatami komórki. Kopiowane lub przenoszone komórki zastępują wszystkie dane w obszarze, w którym są wklejane.

Wpływ kopiowania i przenoszenia na formuły

Podczas przenoszenia formuły nie zmieniają się odwołania do komórek. Podczas kopiowania formuły nie zmieniają się bezwzględne odwołania do komórek, natomiast względne odwołania do komórek zmieniają się zależnie od położenia wklejonej komórki. Jeśli na przykład skopiowano formułę

=A1+B1

z komórki C1 do komórki D2, która jest przesunięta o jedną kolumnę w prawo i jeden wiersz w dół w stosunku do komórki C1, to odwołania w formule zostaną zaktualizowane, aby odzwierciedlić nowe położenie:

=B2+C2

Wpływ filtrowania na kopiowanie i przenoszenie

Jeśli na obszarze zaznaczonym do skopiowania znajdują się komórki ukryte na skutek filtrowania, to będą skopiowane tylko widoczne komórki. Jeśli obszar, w którym wklejono dane, zawiera wiersze ukryte na skutek filtrowania, to może być konieczne wyłączenie filtrowania w celu wyświetlenia wszystkich skopiowanych komórek. Nie można przenieść danych z zakresu zawierającego przefiltrowane wiersze. Aby przenieść dane, należy najpierw wyłączyć filtrowanie.

Kopiowanie do innych programów

Komórki kopiowane z arkusza kalkulacyjnego są umieszczane w Schowku pakietu Office w formatach arkusza kalkulacyjnego XML, HTML i jako zwykły tekst. Wybierany jest najwłaściwszy format dla aplikacji, do której dane są wklejane. Na przykład do arkusza programu Microsoft Excel 2002 komórki są wklejane w formacie arkusza kalkulacyjnego XML, co pozwala odtworzyć formaty formuł, wartości i komórek. W dokumencie programu Microsoft Word komórki są wklejane jako tabela w formacie HTML. Zachowane jest formatowanie komórek i ich wartości, ale nie zachowywane są zawarte w nich formuły. Do Notatnika komórki są wklejane jako zwykły tekst, bez uwzględniania formatowania lub formuł.

Różnice między kopiowaniem w składniku Arkusz kalkulacyjny a kopiowaniem w programie Microsoft Excel

Różnice pomiędzy kopiowaniem i przenoszeniem danych w Arkuszu kalkulacyjnym a kopiowaniem i przenoszenia danych w programie Excel:

Brak wskaźnika kopiowania Komórki skopiowane w arkuszu kalkulacyjnym nie są wyróżnione w programie Excel za pomocą przesuwanego kreskowanego obramowania wskazującego kopiowany obszar.

Brak polecenia Wklej specjalnie Podczas kopiowania komórek w arkuszu kalkulacyjnym można kopiować wartości, formatowanie i formuły. W odróżnieniu od programu Excel nie można wklejać tych elementów niezależnie, zamieniać miejscami wierszy i kolumn podczas wklejania oraz stosować operacji dodawania, odejmowania, mnożenia lub dzielenia.

Podczas wklejania nie można wstawiać komórek Komórki wklejane w arkuszu kalkulacyjnym zawsze zastępują istniejące komórki. W programie Excel można wstawić skopiowane komórki. Aby dodać puste miejsce dla danych kopiowanych lub przenoszonych w arkuszu kalkulacyjnym, przed wklejeniem skopiowanych komórek można wstawić wiersze i kolumny.

Skopiowane dane pozostają w Schowku Podczas kopiowania w arkuszu kalkulacyjnym dane pozostają w Schowku do momentu kopiowania kolejnych danych lub wymazania danych w Schowku. W arkuszu kalkulacyjnym można skopiować dane, następnie wykonać inne operacje, a po ich zakończeniu wkleić dane. Jeśli przed wklejeniem danych w programie Excel zostanie wykonana inna operacja lub naciśnięty klawisz ESC, to zawartość Schowka jest usuwana.

Dane są wycinane natychmiast Podczas przenoszenia danych w arkuszu kalkulacyjnym dane znikają zaraz po wycięciu i mogą być wklejone tylko raz (skopiowane dane mogą być wklejane wielokrotnie). Podczas przenoszenia danych w programie Excel wycięte dane nie są usuwane z oryginalnej lokalizacji do momentu wklejenia i mogą być wklejane wielokrotnie.


Przenoszenie i kopiowanie danych

Przenoszenie lub kopiowanie całych komórek

Podczas kopiowania lub wycinania, a następnie wklejania komórka jest kopiowana lub przenoszona w całości, łącznie z formułami i ich wynikami oraz z formatami komórki.

Jeśli obszar zaznaczony do skopiowania zawiera komórki ukryte podczas filtrowania, to skopiowane zostaną tylko widoczne komórki. Nie można przenieść danych z zakresu zawierającego filtrowane wiersze. Aby przenieść dane, należy najpierw wyłączyć filtrowanie.

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Zaznacz komórki, które chcesz przenieść lub skopiować.
  3. Wykonaj jedną z następujących czynności:

    • Aby przenieść komórki, kliknij przycisk Wytnij [image].

    • Aby skopiować komórki, kliknij przycisk Kopiuj [image].

    Uwaga Po wycięciu danych można je wkleić tylko jeden raz, natomiast po skopiowaniu można je wklejać wiele razy. Chcąc wkleić dane w kilku miejscach, użyj przycisku Kopiuj, aby je skopiować.

  4. Kliknij lewą górną komórkę obszaru, do którego chcesz wkleić komórki.
  5. Kliknij przycisk Wklej [image].

Uwagi

  • Kopiowane lub przenoszone komórki zastępują wszystkie dane w obszarze, do którego są wklejane.
  • Podczas przenoszenia formuły nie zmieniają się zawarte w niej odwołania do komórek. Podczas kopiowania formuły nie zmieniają się odwołania bezwzględne, lecz zmieniają się odwołania względne do komórek.

Przenoszenie lub kopiowanie znaków w obrębie komórki

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Kliknij dwukrotnie komórkę zawierającą znaki, które chcesz przenieść lub skopiować.
  3. W komórce zaznacz znaki, które chcesz przenieść lub skopiować.
  4. Wykonaj jedną z następujących czynności:

    • Aby przenieść znaki, kliknij przycisk Wytnij [image].

    • Aby skopiować znaki, kliknij przycisk Kopiuj [image].

  5. W komórce kliknij miejsce, w którym chcesz wkleić znaki.
  6. Kliknij przycisk Wklej [image].
  7. Naciśnij klawisz ENTER.

Uwaga Podczas przenoszenia lub kopiowania znaków z jednej komórki do innej, przenoszonym lub kopiowanym znakom nadawane jest formatowanie komórki docelowej.


Wstawianie lub usuwanie wierszy lub kolumn

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Wykonaj jedną z następujących czynności:

    Wstawianie wierszy lub kolumn

    1. Kliknij komórkę w kolumnie, na prawo od której chcesz wstawić nową kolumnę lub w wierszu, pod którym chcesz wstawić nowy wiersz.

      Aby wstawić więcej wierszy lub kolumn, zaznacz więcej komórek. Na przykład, aby wstawić trzy wiersze, zaznacz trzy komórki w kolumnie.

    2. Kliknij prawym przyciskiem myszy komórkę lub zaznaczenie, wskaż polecenie Wstaw w menu skrótów, a następnie kliknij polecenie Wiersze lub Kolumny.

    Usuwanie wierszy lub kolumn

    1. Kliknij komórkę w kolumnie lub wierszu, które chcesz usunąć.

      Aby usunąć więcej wierszy lub kolumn, zaznacz więcej komórek. Na przykład, aby usunąć trzy wiersze, zaznacz trzy komórki w kolumnie.

    2. Kliknij prawym przyciskiem myszy komórkę lub zaznaczenie, wskaż polecenie Usuń w menu skrótów, a następnie kliknij polecenie Wiersze lub Kolumny.

    Uwagi

    • Nie można usunąć wierszy lub kolumn z zakresu zawierającego filtrowane wiersze. Aby usunąć te wiersze lub kolumny, należy najpierw wyłączyć filtrowanie, klikając przycisk Autofiltr [image], aby przestał być zaznaczony.
    • Po usunięciu danych, które są wykorzystywane w formule w innym miejscu arkusza kalkulacyjnego, w komórce tej formuły zostanie wyświetlona wartość błędu, na przykład #ADR.


Wstawianie, zmiana lub usuwanie hiperłącza

Wstaw hiperłącze

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Kliknij komórkę, w której chcesz wstawić hiperłącze.
  3. Wpisz adres zaczynający się od prawidłowego identyfikatora protokołu, takiego jak http://, a następnie naciśnij klawisz ENTER, aby wprowadzić adres jako hiperłącze. Na przykład, http://przykład.microsoft.com

Uwaga W komórce adres pojawia się jako niebieski podkreślony tekst. Aby wyświetlany tekst hiperłącza był inny niż jego adres, należy użyć funkcji HIPERŁĄCZE arkusza kalkulacyjnego.

Zmiana hiperłącza

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Kliknij komórkę obok hiperłącza, a następnie użyj klawiszy strzałek, aby przejść do komórki z hiperłączem.
  3. Naciśnij klawisz F2, aby rozpocząć edycję w komórce.
  4. Wpisz zmieniony adres hiperłącza lub formułę używającą funkcji HIPERŁĄCZE arkusza kalkulacyjnego.

Uwaga Podczas modyfikowania hiperłącza, które zostało opublikowane z arkusza kalkulacyjnego Microsoft Excel i utworzone pierwotnie za pomocą okna dialogowego Wstaw hiperłącze programu Excel, można zmienić tekst wyświetlany jako hiperłącze, ale nie można zmienić adresu, do którego ono prowadzi.

Usuwanie hiperłącza

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Kliknij komórkę obok hiperłącza, a następnie użyj klawiszy strzałek, aby przejść do komórki z hiperłączem.
  3. Naciśnij klawisz DELETE.


Czyszczenie zawartości komórek

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Zaznacz komórki, które chcesz wyczyścić.
  3. Naciśnij klawisz DELETE.

Porada

Wyczyszczenie zawartości komórek powoduje usunięcie wartości i formuł, ale nie usuwa formatowania. Aby usunąć wartości, formuły i formatowanie, zaznacz komórki, a następnie kliknij przycisk Wytnij [image].


Formuły — informacje

Co to jest formuła?

Formuła jest równaniem, w którym operacje są wykonywane na podstawie danych z arkusza kalkulacyjnego lub innych danych. Formuły mogą wykonywać operacje matematyczne, na przykład dodawanie i mnożenie, łączyć tekst lub porównywać wartości w arkuszu kalkulacyjnym. Następująca formuła dodaje wartość w komórce A1 arkusza kalkulacyjnego do wartości w komórce A2:

=A1+A2

Formuły mogą używać stałych (na przykład, wartości liczbowych lub tekstowych), odwoływać się do komórek arkusza kalkulacyjnego lub wykorzystywać wartości danych znajdujących się na tej samej stronie sieci Web.

Elementy formuły

Formuła w arkuszu kalkulacyjnym zawsze rozpoczyna się od znaku równości (=). Za znakiem równości znajdują się elementy, na których wykonywane są obliczenia (operandy), rozdzielone operatorami. Operatory to symbole określające typ obliczeń — na przykład dodawanie (+), mnożenie (*) i odejmowanie (-) — które mają być wykonane na elementach formuły.

Obliczenia

Formuły są obliczane od lewej do prawej, począwszy od znaku równości i zgodnie z priorytetami operatorów w formule. Na przykład, mnożenie jest wykonywane przed dodawaniem.

=5+2*3*4

W powyższym przykładzie najpierw wykonywana jest pierwsza z lewej operacja mnożenia (2*3), która daje w wyniku 6, a następnie kolejna od lewej operacja mnożenia (6*4), co daje w wyniku 24. Na końcu wykonywana jest operacja dodawania (5+24), co daje w wyniku 29.

Kolejność obliczeń można kontrolować, zmieniając składnię formuły. Na przykład, w następującym przykładzie nawiasy zostały wykorzystane do zmiany składni powyższego przykładu, co spowodowało, że liczby 5 i 2 są dodawane jako pierwsze (5+2), następnie wynik (7) jest mnożony przez 3, a następnie otrzymany wynik (21) jest mnożony przez 4, co daje w rezultacie 84.

=(5+2)*3*4

Domyślnie arkusz jest obliczany automatycznie, co oznacza, że po zmianie zawartości komórki, do której odwołuje się formuła, dana formuła jest obliczana ponownie. Można jednak ustawić obliczanie ręczne, dzięki czemu formuły będą obliczane jedynie na żądanie użytkownika.

Stałe a odwołania do komórek

Formuła może odwoływać się do wartości stałych i do innych komórek. Komórka zawierająca formułę jest komórką zależną, jeśli jej wartość zależy od wartości w innych komórkach. Na przykład, komórka B2 jest zależna, jeśli zawiera formułę =C2.

Domyślnie, po każdej zmianie zawartości komórki, do której odwołuje się formuła, zmienia się również komórka zależna. Na przykład, jeśli zmieni się wartość w jednej z następujących komórek, to zmieni się również wynik formuły =B2+C2+D2.

Dane w arkuszu kalkulacyjnym

Jeśli w formule używane są wartości stałe, a nie odwołania do komórek (na przykład, =30+70+110), to jej wynik zmieni się tylko w przypadku modyfikacji samej formuły.

Funkcje

Składnik Arkusz kalkulacyjny pakietu Microsoft Office oferuje wiele wstępnie zdefiniowanych lub wbudowanych formuł, znanych jako funkcje. Funkcji można używać do wykonywania zarówno prostych, jak i złożonych obliczeń. Na przykład następująca formuła wykorzystuje funkcję SUMA, aby dodać zakres komórek:

=SUMA(A1:A5)


Przykłady często używanych formuł

Tworzenie sumy na podstawie jednego warunku

Funkcji arkusza kalkulacyjnego SUMA.JEŻELI można użyć do utworzenia sumy jednego zakresu na podstawie wartości w innym zakresie. Na przykład, następująca formuła oblicza sumę odpowiednich komórek w zakresie F5:F25 dla każdej zawierającej wartość „Northwind” komórki w zakresie B5:B25.

=SUMA.JEŻELI(B5:B25,"Northwind",F5:F25)

Zliczanie wystąpień wartości lub warunku

Funkcja LICZ.JEŻELI arkusza kalkulacyjnego zlicza wystąpienia wartości w zakresie komórek — na przykład, liczbę komórek w zakresie B5:B25 zawierających tekst „Northwind”.

=LICZ.JEŻELI(B5:B25,"Northwind")

Obliczanie salda bieżącego

W arkuszu kalkulacyjnym można utworzyć rejestr książeczki czekowej umożliwiający śledzenie transakcji bankowych. Jako część arkusza kalkulacyjnego można skonstruować formułę obliczającą saldo bieżące. W tym przykładzie załóżmy, że komórka F6 zawiera poprzednie saldo, komórka D7 sumę częściową depozytu pierwszej transakcji, a komórka E7 otrzymaną kwotę gotówkową.

Aby obliczyć saldo bieżące dla pierwszej transakcji, należy wprowadzić w komórce F7 następującą formułę:

=SUMA(F6,D7,–E7)

W miarę wprowadzania nowych transakcji, należy skopiować tę formułę do komórki salda bieżącego każdego nowego depozytu.

Łączenie imion i nazwisk

Używając znaku & (handlowe i) jako operatora tekstowego, można za pomocą formuły łączyć listy imion z jednej kolumny z listą nazwisk z innej kolumny. W tych przykładach założono, że komórka D5 zawiera imię, a komórka E5 zawiera nazwisko.

Aby wyświetlić imię i nazwisko w formacie „imię nazwisko” (na przykład „Jan Kowalski”):

=D5&" "&E5

Aby wyświetlić imię i nazwisko w formacie „nazwisko, imię” (na przykład „Kowalski, Jan”):

=E5&", "&D5

Łączenie daty z tekstem

Aby połączyć dwie wartości i utworzyć pojedynczą ciągłą wartość tekstową, można użyć operatora tekstowego & (handlowe i). Aby połączyć ciąg tekstowy z liczbą, datą lub godziną przechowywaną w komórce, należy wykorzystać funkcję TEKST arkusza kalkulacyjnego. Na przykład, jeśli komórka G5 zawiera datę wystawienia rachunku 5-Cze-2000, można wyświetlić tekst „Data rachunku: 5-Cze-2000” za pomocą następującej formuły:

="Data rachunku: "&TEKST(G5, "d-mmm-rrrr")

Zwiększanie liczby o określoną wielkość procentową

Wartość liczbową przechowywaną w komórce można zwiększyć o określoną wielkość procentową. W tym przykładzie założono, że komórka G5 zawiera wartość, która ma być zwiększona o 5 procent. Wartość komórki G5 należy pomnożyć przez 1, aby otrzymać wartość początkową, a następnie dodać wielkość procentową, o jaką ta wartość ma być zwiększona, co sprawi, że formuła zwróci w wyniku powiększoną wartość.

=G5*(1+5%)

Jeśli wielkość procentowa jest przechowywana w komórce G2, należy użyć następującej formuły:

=G5*(1+$G$2)

Odwołanie do komórki G2 jest odwołaniem bezwzględnym, dzięki czemu formułę można kopiować do innych komórek bez zmiany odwołania do komórki G2.


Tworzenie formuły

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Kliknij komórkę, w której chcesz dodać formułę.
  3. Wpisz znak równości (=).
  4. Wpisz formułę.
  5. Naciśnij klawisz ENTER.

Porada

Aby automatycznie wstawić sumę zakresu komórek, zaznacz pierwszą pustą komórkę znajdującą się za danymi, poniżej kolumny danych albo po prawej stronie wiersza danych, które chcesz zsumować, kliknij przycisk Autosumowanie Autosumowanie na pasku narzędzi arkusza kalkulacyjnego, a następnie naciśnij klawisz ENTER.


Zmiana formuły

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Kliknij dwukrotnie komórkę zawierającą formułę, którą chcesz zmienić, aby formuła pojawiła się w komórce.

    Jeżeli komórka zawiera hiperłącze, kliknij komórkę obok komórki, którą chcesz zmienić, a następnie użyj klawisza strzałki do zaznaczenia komórki z formułą, którą chcesz zmienić. Następnie naciśnij klawisz F2.

  3. Dokonaj zmian formuły w komórce.
  4. Naciśnij klawisz ENTER.


Jednoczesne wyświetlanie formuły i jej wyniku

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Kliknij komórkę zawierającą formułę, którą chcesz wyświetlić.
  3. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Formuła.
  4. Przejrzyj formułę w polu Formuła w komórce aktywnej (odwołanie). Wynik formuły jest wyświetlany w polu Wartość komórki.


Wstawianie sumy zakresu

Można automatycznie wstawić sumę zakresu komórek, używając polecenia Autosumowanie.

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Kliknij pierwszą pustą komórkę znajdującą się za danymi, poniżej kolumny danych albo po prawej stronie wiersza danych, które chcesz zsumować lub zaznacz zakres w kolumnie, który chcesz zsumować.
  3. Na pasku narzędzi kliknij przycisk Autosumowanie [image].

    Sugerowana formuła zostanie wyświetlona w zaznaczonej komórce lub w komórce znajdującej się poniżej zaznaczonego zakresu w kolumnie.

  4. Wykonaj jedną z następujących czynności:

    • Aby zaakceptować sugerowaną formułę, naciśnij klawisz ENTER.

    • Aby zmienić sugerowaną formułę, zaznacz zakres, który chcesz sumować i naciśnij klawisz ENTER.


Zmiana sposobu wykonywania obliczeń przez arkusz kalkulacyjny

Jeśli arkusz kalkulacyjny zawiera wiele formuł, to ich obliczenie może trwać długo. Aby przyspieszyć pracę, można zmienić tryb obliczeń z automatycznego na ręczny, co pozwala decydować, kiedy arkusz kalkulacyjny ma być ponownie obliczony.

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Na pasku narzędzi arkusza kalkulacyjnego kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Skoroszyt.
  3. W obszarze Obliczanie wykonaj jedną z następujących czynności:

    • Aby obliczać ponownie arkusz kalkulacyjny po każdej zmianie wartości, zaznacz opcję Automatyczne.

    • Aby obliczać ponownie arkusz kalkulacyjny jedynie po naciśnięciu klawisza F9 lub kliknięciu przycisku Oblicz, zaznacz opcję Ręczne.


Używanie nazw w formułach — informacje

Przegląd

Zdefiniowana nazwa w formule może ułatwić zrozumienie celu formuły. Na przykład, formuła =SUMA(SprzedażWPierwszymKwartale) będzie łatwiejsza do rozpoznania niż =SUMA(C20:C30).

Nazwy są dostępne na każdym arkuszu. Na przykład, jeśli nazwa PlanowanaSprzedaż odwołuje się do zakresu A20:A30 na pierwszym arkuszu, to można jej użyć na każdym innym arkuszu, aby odwołać się do zakresu A20:A30 na pierwszym arkuszu.

Nazw można także używać do oznaczania formuł lub wartości, które nie ulegają zmianie (stałych). Na przykład, można użyć nazwy PodatekOdSprzedaży, aby oznaczyć wysokość podatku od sprzedaży (na przykład 6,2 procent) stosowanego w transakcjach sprzedaży.

Uwaga Domyślnie nazwy używają bezwzględnych odwołań do komórek.

Zasady

Jakie znaki są dopuszczalne? Pierwszym znakiem w nazwie musi być litera lub podkreślenie. Pozostałe znaki mogą być literami, cyframi, kropkami i podkreśleniami.

Czy nazwy mogą być odwołaniami do komórek? Nazwy nie mogą być takie same, jak odwołania do komórek, na przykład Z$100 lub W1K1.

Czy można używać więcej niż jednego wyrazu? Tak, ale nie można używać spacji. Jako separatorów wyrazów można użyć kropek lub podkreśleń — na przykład Podatek_od_sprzedaży lub Pierwszy.kwartał.

Ile znaków można użyć? Nazwa może się składać maksymalnie z 255 znaków.

Czy ważna jest wielkość liter w nazwach? Nazwy mogą zawierać duże i małe litery. Składnik Arkusz kalkulacyjny nie rozróżnia wielkości liter w nazwach. Na przykład, jeśli utworzono nazwę Sprzedaż, a następnie w tym samym arkuszu kalkulacyjnym utworzono inną nazwę SPRZEDAŻ, to zastąpi ona pierwszą z tych nazw.


Definiowanie nazw komórek, formuł lub stałych

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Formuła.
  3. W obszarze Nazwy wpisz nazwę, której chcesz używać w polu Nazwa.

    Aby zdefiniować nazwę, która ma być dostępna tylko na jednym arkuszu (nazwę lokalną), przed nazwą, której chcesz użyć, wpisz nazwę arkusza i wykrzyknik. Na przykład, chcąc nadać komórce nazwę Budżet i udostępnić ją tylko w arkuszu Arkusz2, w polu Nazwa wpisz następujący ciąg:

    Arkusz2!Budżet

  4. W polu Odwołuje się do wpisz = (znak równości), a następnie formułę, stałą albo odwołanie do komórki lub zakresu komórek, który chcesz nazwać. Na przykład, aby nazwać komórki od A1 do A5 w arkuszu Arkusz1 wpisz następujący ciąg:

    =Arkusz1!$A$1:$A$5

  5. Kliknij przycisk Definiuj.


Zmiana lub usuwanie nazwy zdefiniowanej

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Formuła.
  3. W obszarze Nazwy, w polu Wszystkie nazwy kliknij nazwę, którą chcesz zmienić lub usunąć.
  4. Wykonaj jedną z następujących czynności:
    • Aby zmienić nazwę, wpisz nową nazwę w polu Nazwa i kliknij przycisk Definiuj. Następnie kliknij oryginalną nazwę w polu Wszystkie nazwy i kliknij przycisk Usuń.
    • Aby zmienić komórkę, formułę lub stałą reprezentowaną za pomocą nazwy, zmień nazwę w polu Odwołuje się do, a następnie kliknij przycisk Definiuj.
    • Aby usunąć nazwę, kliknij przycisk Usuń.


Odwołania do komórek i zakresów — informacje

Przegląd

Odwołanie identyfikuje komórkę lub zakres komórek w arkuszu kalkulacyjnym i informuje arkusz kalkulacyjny, gdzie należy szukać wartości lub danych, które mają być użyte w formule. Używając odwołań, można wykorzystać dane znajdujące się w różnych częściach arkusza kalkulacyjnego w jednej formule albo użyć wartości z jednej komórki w kilku formułach.

Arkusze kalkulacyjne używają stylu odwołań A1, w którym kolumny mają etykiety literowe (od A do ZZZ, co daje w sumie 18 278 kolumn), a wiersze etykiety liczbowe (od 1 do 262 144).

Aby odwołać się do komórki, należy wprowadzić literę kolumny, a następnie numer wiersza. Na przykład, D50 odwołuje się do komórki leżącej na przecięciu kolumny D i wiersza 50.

Aby odwołać się do zakresu komórek, należy wprowadzić odwołanie do komórki znajdującej się w lewym górnym rogu zakresu, a następnie wpisać dwukropek (:) i wprowadzić odwołanie do komórki znajdującej się w prawym dolnym rogu zakresu. Poniżej znajdują się przykłady odwołań.

Aby odwołać się do | Użyj
Komórki w kolumnie A i wierszu 10. | A10
Zakresu komórek w kolumnie A i wierszach od 10. do 20. | A10:A20
Zakresu komórek w wierszu 15. i kolumnach od B do E | B15:E15
Wszystkich komórek w wierszu 5. | 5:5
Wszystkich komórek w wierszach od 5. do 10. | 5:10
Wszystkich komórek w kolumnie H | H:H
Wszystkich komórek w kolumnach od H do J | H:J
Zakresu komórek w kolumnach od A do E i wierszach od 10. do 20. | A10:E20

Odwołania względne i bezwzględne

Odwołania względne Podczas tworzenia formuły zawierającej odwołania do komórek lub zakresów odwołania są zazwyczaj oparte na pozycji komórek względem komórki zawierającej formułę. W następującym przykładzie komórka B6 zawiera formułę =A5. Wartość znajduje się o jedną komórkę powyżej i jedną komórkę na lewo od komórki B6. Jest to określane jako odwołanie względne.

Formuła z odwołaniem względnym

Kopiowanie i wklejanie formuły używającej odwołań względnych powoduje automatyczne dopasowanie odwołań w formule, aby odwoływały się do innych komórek względem położenia formuły. W następującym przykładzie formuła w komórce B2, =A1, odwołuje się do komórki znajdującej się powyżej i na lewo komórki B2. Po wklejeniu formuły do komórki B3, formuła zostanie zmieniona na formułę =A2, która odwołuje się do komórki leżącej o jeden wiersz w górę i o jedną kolumnę w lewo względem komórki B3.

Skopiowana formuła zawierająca odwołanie względne

Odwołania bezwzględne Aby odwołania nie były dopasowywane podczas kopiowania formuły do innej komórki, należy użyć odwołania bezwzględnego. W celu utworzenia odwołania bezwzględnego należy wpisać znak dolara ($) przed tymi częściami odwołania, które nie mają się zmieniać. Na przykład, aby w formule =A5*C1 utworzyć odwołanie bezwzględne do komórki C1, należy w następujący sposób dodać do formuły znaki dolara:

=A5*$C$1

Odwołania mieszane Można także utworzyć takie odwołanie, w którym tylko wiersz lub tylko kolumna będzie odwołaniem bezwzględnym. Odwołania takie są znane jako odwołania mieszane. Na przykład, chcąc skopiować formułę, w której aktualizowane będzie tylko odwołanie do kolumny, a nie do wiersza, należy umieścić symbol dolara tylko przed numerem wiersza:

=C$1

Porada

Aby szybko przechodzić pomiędzy odwołaniami względnymi i bezwzględnymi, należy zaznaczyć odwołanie w formule i nacisnąć klawisz F4. Każde naciśnięcie klawisza F4 powoduje zmianę typu odwołania od bezwzględnej kolumny i bezwzględnego wiersza, przez względną kolumnę i bezwzględny wiersz do względnej kolumny i względnego wiersza i z powrotem do bezwzględnej kolumny i bezwzględnego wiersza.


Obliczenia — informacje

Obliczanie to proces, którego arkusz kalkulacyjny używa do obliczania formuł w komórkach, a następnie wyświetlania wyników jako wartości. Domyślnie formuły są obliczane automatycznie w momencie zmiany zawartości komórek, do których się odwołują. Można jednak zmienić sposób, w jaki arkusz kalkulacyjny oblicza dane.

Wartości przechowywane a wartości wyświetlane Wartości są czasami wyświetlane i przechowywane w różny sposób. Na przykład, daty i godziny są przechowywane jako kolejne liczby, ale wyświetlane i drukowane zazwyczaj w jednym z kilku formatów dat i godzin. Arkusz kalkulacyjny używa przechowywanych liczb kolejnych w obliczeniach, dzięki czemu możliwe jest obliczenie liczby dni pomiędzy dwiema datami.

Format wyświetlania przechowywanych wartości czasami zależy od sposobu ich formatowania. Można, na przykład, za pomocą formatu naukowego tak sformatować komórkę zawierającą liczbę 123456789, aby była ona wyświetlana jako 1,23E+08. Można też tak sformatować komórkę zawierającą datę o liczbie kolejnej 36699, aby była ona wyświetlana jako „2000-06-22” lub „22-Cze-2000”. Zmiana sposobu wyświetlania wartości nie zmienia wartości przechowywanej.

Ustawienia regionalne wybrane w Panelu sterowania systemu Microsoft Windows również określają sposób wyświetlania formatów liczb, walut, dat i godzin. Ustawienia te określają na przykład, czy lata będą wyświetlane za pomocą dwóch czy czterech cyfr. Informacje o tych formatach można znaleźć w Pomocy systemu Windows.


Operatory obliczeniowe — informacje

Operatory określają typy obliczeń, które mają być wykonane na elementach formuły. Składnik Arkusz kalkulacyjny zawiera cztery typy operatorów obliczeniowych: arytmetyczne, porównania, łączenia tekstu i odwołania. Działania odpowiadające operatorom są wykonywane w określonej kolejności.

Typy operatorów

Arytmetyczne

Następujące operatory arytmetyczne umożliwiają wykonywanie podstawowych operacji matematycznych, na przykład dodawania, odejmowania lub mnożenia; łączenie liczb i otrzymywanie wyników numerycznych.

Operator arytmetyczny | Znaczenie | Przykład
+ (znak plus) | Dodawanie | 3+3
– (znak minus) | Odejmowanie Negacja | 3–1 –1
* (gwiazdka) | Mnożenie | 3*3
/ (kreska ułamkowa) | Dzielenie | 3/3
% (znak procent) | Procentowy | 20 %
^ (daszek) | Potęgowanie | 3^2 (to samo co 3*3)

Porównania

Następujące operatory porównania umożliwiają porównanie dwóch wartości. Wynik porównywania dwóch wartości za pomocą tych operatorów jest wartością logiczną, równą PRAWDA albo FAŁSZ.

Operator porównania | Znaczenie | Przykład
= (znak równości) | Równe | A1=B1
> (znak większości) | Większe niż | A1>B1
< (znak mniejszości) | Mniejsze niż | A1<B1
>= (znak większe lub równe) | Większe lub równe | A1>=B1
<= (znak mniejsze lub równe) | Mniejsze niż lub równe | A1<=B1
<> (znak nierówności) | Nierówne | A1<>B1

Łączenie tekstu

Aby połączyć jeden lub kilka ciągów tekstowych i utworzyć pojedynczy tekst, należy użyć operatora & (handlowe i).

Operator tekstowy | Znaczenie | Przykład
& (handlowe i) | Łączenie tekstu | Wynikiem "North" & "wind" jest "Northwind"

Odwołania

Aby połączyć zakresy komórek w obliczeniach, należy użyć następujących operatorów odwołania.

Operator odwołania | Znaczenie | Przykład
: (dwukropek) | Operator zakresu, tworzący jedno odwołanie do wszystkich komórek leżących między podanymi odwołaniami, łącznie z tymi odwołaniami | B5:B15
; (średnik) | Operator sumy zbiorów, łączący kilka odwołań w jedno | SUMA(B5:B15;D5:D15)
(pojedyncza spacja) | Operator iloczynu zbiorów, tworzący jedno odwołanie do komórek leżących w części wspólnej dwóch odwołań | SUMA(B5:B15 A7:D7) W tym przykładzie komórka B7 należy do obu zakresów.

Kolejność wykonywania działań odpowiadających operatorom

Jeśli jedna formuła składa się z kilka operatorów, to składnik Arkusz kalkulacyjny wykonuje operacje w kolejności przedstawionej w poniższej tabeli. Jeśli formuła zawiera operatory o tym samym priorytecie — na przykład operatory mnożenia i dzielenia — składnik Arkusz kalkulacyjny wykonuje odpowiadające operatorom działania od lewej do prawej. Aby zmienić kolejność wykonywania działań, należy ująć w nawiasy tę część formuły, która ma być obliczana jako pierwsza.

Operator | Opis
: (dwukropek) (pojedyncza spacja) ; (średnik) | Operatory odwołania
– | Negacja (tak, jak w -1)
% | Procentowy
^ | Potęgowanie
* i / | Mnożenie i dzielenie
+ i - | Dodawanie i odejmowanie
& | Łączenie tekstu (łączenie dwóch ciągów tekstowych)
= < > <= >= <> | Porównanie


Tworzenie formuły używającej danych z tej samej strony sieci Web — informacje

Można zwrócić wartość w komórce na podstawie danych znajdujących się na tej samej stronie sieci Web co arkusz kalkulacyjny, używając funkcji HOST składnika arkusz kalkulacyjny. Na przykład, jeśli na stronie jest pole tekstowe o nazwie Pole tekstowe 1, następująca formuła pobierze wartość z pola tekstowego i wyświetli ją w komórce zawierającej formułę:

=HOST().pole tekstowe 1.wartość

Można także tworzyć formuły wykonujące obliczenia na wartościach zwróconych ze strony sieci Web. Na przykład, jeśli pole tekstowe, z którego zwracana jest wartość, zawiera wielkość sprzedaży, a komórka C1 w arkuszu zawiera współczynnik prowizji, to można pomnożyć wartość zwróconą ze strony sieci Web przez wartość z komórki C1:

=$C$1*HOST().pole tekstowe 1.wartość

Można także odwoływać się do wartości w innym arkuszu kalkulacyjnym na tej samej stronie sieci Web. Na przykład, jeśli na stronie sieci Web są arkusze o nazwach arkusz1 i arkusz2, wówczas poniższa formuła w arkuszu arkusz1 zwraca wartość z komórki A1 w arkuszu arkusz2:

=HOST().arkusz2.zakres("a1").wartość

Aby uzyskać więcej informacji dotyczących funkcji, formantów i właściwości, z których można korzystać w arkuszu kalkulacyjnym, zapoznaj się z tematami Pomocy dotyczącymi programowania arkuszy kalkulacyjnych


Formuły tablicowe i stałe tablicowe — informacje

Formuła tablicowa może wykonywać wiele obliczeń, a następnie zwracać pojedynczy wynik lub wiele wyników. Formuły tablicowe działają na dwóch lub większej liczbie zbiorów wartości znanych jako argumenty tablicowe. Każdy argument tablicowy musi mieć taką samą liczbę wierszy i kolumn. Formuły tablicowe tworzy się w taki sam sposób, jak inne formuły, z tym że w celu wprowadzenia formuły tablicowej należy nacisnąć klawisze CTRL+SHIFT+ENTER. Podczas edycji formuła tablicowa jest wyświetlana kursywą.

Stałych tablicowych można używać zamiast odwołań, aby uniknąć wprowadzania wartości poszczególnych stałych w różnych komórkach arkusza.

Niektóre z wbudowanych funkcji są formułami tablicowymi i trzeba je wprowadzać jako tablice, aby uzyskać poprawne wyniki.

Korzystanie z formuł tablicowych

Obliczanie pojedynczego wyniku Ten typ formuły tablicowej może uprościć model arkusza kalkulacyjnego, zastępując wiele różnych formuł jedną formułą tablicową.

Na przykład, poniższa formuła tablicowa oblicza wartość całkowitą tablicy cen akcji i udziałów, bez używania wiersza komórek do obliczania i wyświetlania poszczególnych wartości każdej akcji.

Formuła tablicowa dająca pojedynczy wynik

Formuła =SUMA(B2:C2*B3:C3) wprowadzona jako formuła tablicowa pomnoży liczbę udziałów (w komórkach B2 i C2) przez cenę (w komórkach B3 i C3) każdej akcji, a następnie doda do siebie wyniki tych obliczeń.

Obliczanie wielu wyników Niektóre funkcje arkusza kalkulacyjnego zwracają tablicę wartości lub wymagają podania tablicy wartości jako argumentu. Aby obliczyć wiele wyników za pomocą formuły tablicowej, należy wprowadzić tablicę do zakresu komórek, który ma tę samą liczbę wierszy i kolumn, co argumenty tablicowe.

Na przykład, jeśli podano trzy wielkości sprzedaży (20 234, 21 003 i 10 000 w kolumnie B) w czasie trzech miesięcy (1, 2 i 3 w kolumnie A), to funkcja REGLINW określi wartości liniowe dla tych wielkości sprzedaży. Aby wyświetlić wszystkie wyniki tej formuły, można ją wprowadzić w trzech komórkach w kolumnie C (C1:C3).

Formuła tablicowa dająca wiele wyników

Formuła =REGLINW(B1:B3;A1:A3) wprowadzona jako formuła tablicowa daje trzy oddzielne wyniki (22 196, 17 079 i 11 962, które mogłyby zostać wyświetlone w komórkach C1, C2 i C3) na podstawie trzech podanych wielkości sprzedaży i trzech miesięcy.

Korzystanie ze stałych tablicowych

W zwykłej formule można wprowadzić odwołanie do komórki zawierającej wartość lub samą wartość, która nazywana jest wtedy stałą. W przypadku formuły tablicowej również można wprowadzić odwołanie do tablicy lub tablicę wartości zawartych w komórkach, co nazywane jest stałą tablicową. Formuły tablicowe akceptują stałe w taki sam sposób, jak formuły nietablicowe, ale stałe tablicowe muszą być wprowadzane w określonym formacie.

Stałe tablicowe mogą zawierać liczby, tekst, wartości logiczne, na przykład PRAWDA lub FAŁSZ albo wartości błędów, na przykład #N/D!. W tej samej stałej tablicowej mogą się znajdować różne typy wartości — na przykład {1;3;4\PRAWDA;FAŁSZ;PRAWDA}. Liczby w stałych tablicowych mogą być wartościami całkowitymi, ułamkowymi lub mogą być zapisane w notacji naukowej. Tekst musi być ujęty w cudzysłowy — na przykład "Wtorek".

Stałe tablicowe nie mogą zawierać odwołań do komórek, kolumn ani wierszy o różnych długościach, formuł lub znaków specjalnych, takich jak $ (symbol dolara), nawiasy czy % (procent).

Format stałych tablicowych

Stałe tablicowe są ujęte w nawiasy klamrowe ( { } ).

Wartości w kolumnach są rozdzielane średnikami (;). Na przykład, aby przedstawić wartości 10, 20, 30 i 40, należy wprowadzić ciąg {10;20;30;40}. Taka stała tablicowa jest tablicą 1 na 4 i odpowiednikiem odwołania do zakresu o jednym wierszu i czterech kolumnach.

Wartości w poszczególnych wierszach są rozdzielane kreskami ułamkowymi odwróconymi (\). Na przykład, aby przedstawić wartości 10, 20, 30 i 40 w jednym wierszu, a 50,60,70 i 80 w wierszu poniżej, można wprowadzić stałą tablicową o rozmiarach 2 na 4: {10;20;30;40\50;60;70;80}.


Tworzenie formuł tablicowych

Obliczanie pojedynczego wyniku

Formuły tablicowej można użyć do wykonania wielu obliczeń w celu wygenerowania pojedynczego wyniku. Ten typ formuły może uprościć model arkusza kalkulacyjnego, zastępując wiele różnych formuł jedną formułą tablicową.

  1. Kliknij komórkę, do której chcesz wprowadzić formułę tablicową.
  2. Wpisz formułę tablicową.

    Na przykład, poniższa formuła oblicza całkowitą wartość tablicy cen akcji i udziałów, bez używania wiersza komórek do obliczania i wyświetlania poszczególnych wartości każdej akcji.

    Formuła tablicowa dająca pojedynczy wynik

    Formuła =SUMA(B2:C2*B3:C3) wprowadzona jako formuła tablicowa pomnoży liczbę udziałów (w komórkach B2 i C2) przez cenę (w komórkach B3 i C3) każdej akcji, a następnie doda do siebie wyniki tych obliczeń.

  3. Naciśnij klawisze CTRL+SHIFT+ENTER.

Obliczanie wielu wyników

Niektóre funkcje arkusza kalkulacyjnego zwracają tablicę wartości lub wymagają podania tablicy wartości jako argumentu. Aby obliczyć wiele wyników za pomocą formuły tablicowej, należy wprowadzić tablicę do zakresu komórek, który ma tę samą liczbę wierszy i kolumn, co argumenty tablicowe.

  1. Zaznacz zakres komórek, do których chcesz wprowadzić formułę tablicową.
  2. Wpisz formułę tablicową.

    Na przykład, jeśli podano trzy wielkości sprzedaży (20 234, 21 003 i 10 000 w kolumnie B) w czasie trzech miesięcy (1, 2 i 3 w kolumnie A), to funkcja REGLINW określi wartości liniowe tych wielkości sprzedaży. Aby wyświetlić wszystkie wyniki tej formuły, można ją wprowadzić w trzech komórkach w kolumnie C (C1:C3).

    Formuła tablicowa dająca wiele wyników

    Formuła =REGLINW(B1:B3;A1:A3) wprowadzona jako formuła tablicowa daje trzy oddzielne wyniki (22 196, 17 079 i 11 962, które mogłyby zostać wyświetlone w komórkach C1, C2 i C3) na podstawie trzech podanych wielkości sprzedaży i trzech miesięcy.

  3. Naciśnij klawisze CTRL+SHIFT+ENTER.


Edycja formuły tablicowej

Jeśli formuła tablicowa zajmuje wiele komórek, należy tak edytować cały zakres, jakby była to jedna komórka. Nie można zmienić tylko jednego elementu formuły tablicowej.

  1. Zaznacz komórkę zawierającą formułę tablicową lub, jeśli formuła zajmuje wiele komórek, zaznacz zakres zawierający formułę tablicową.

    Jak?

    1. Zaznacz komórkę w tablicy.
    2. Naciśnij klawisze CTRL+/ (klawisz znaku kreski ułamkowej).
  2. Naciśnij klawisz F2.
  3. Wprowadź zmiany w formule tablicowej.
  4. Naciśnij klawisze CTRL+SHIFT+ENTER.


Zaznaczanie zakresu formuły tablicowej

  1. Zaznacz komórkę w tablicy.
  2. Naciśnij klawisze CTRL+/ (klawisz znaku kreski ułamkowej).


Przenoszenie lub kopiowanie formuły tablicowej

  1. Zaznacz cały zakres tablicy.

    Jak?

    1. Zaznacz komórkę w tablicy.
    2. Naciśnij klawisze CTRL+/ (klawisz znaku kreski ułamkowej).
  2. Kliknij przycisk Wytnij [image] lub Kopiuj [image] na pasku narzędzi.
  3. Zaznacz cały zakres docelowy — w przeciwnym wypadku tablica zostanie wklejona do pojedynczej komórki.
  4. Kliknij przycisk Wklej [image] .


Używanie funkcji arkusza kalkulacyjnego — informacje

Funkcje to wstępnie zdefiniowane formuły, które wykonują obliczenia za pomocą określonych wartości — argumentów — w ustalonej kolejności lub strukturze. Na przykład, funkcja SUMA sumuje wartości lub zakresy komórek, a funkcja PMT oblicza spłaty pożyczki na podstawie stopy procentowej, terminu spłaty oraz kwoty pożyczki. Zobacz listę dostępnych funkcji arkusza kalkulacyjnego.

Argumenty Argumentami mogą być liczby, tekst, wartości logiczne, takie jak PRAWDA lub FAŁSZ, wartości błędu, na przykład #N/D!, odwołania do komórek, stałe, formuły lub inne funkcje. Każdy argument musi dawać prawidłową wartość dla danego argumentu.

Struktura Struktura funkcji składa się z nazwy, nawiasu otwierającego, argumentów rozdzielonych średnikami i nawiasu zamykającego. Jeśli funkcja rozpoczyna formułę, to przed nazwą funkcji należy wpisać znak równości (=).

Funkcje zagnieżdżone

W niektórych przypadkach konieczne może być użycie funkcji jako jednego z argumentów innej funkcji. Na przykład, następująca formuła używa zagnieżdżonej funkcji ŚREDNIA i porównuje wynik z wartością 50.

Prawidłowe wartości zwracane Jeśli funkcja zagnieżdżona jest używana jako argument, to musi zwracać wartość tego samego typu, jakiego używa dany argument. Na przykład, jeśli argument zwraca wartość PRAWDA lub FAŁSZ, zagnieżdżona funkcja również musi zwracać wartość PRAWDA lub FAŁSZ. W przeciwnym wypadku arkusz kalkulacyjny wyświetli wartość błędu #ARG!.


Formatowanie komórek arkusza kalkulacyjnego

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Zaznacz komórki, które chcesz formatować.
  3. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Format.
  4. Wykonaj co najmniej jedną z następujących czynności:

    Zmiana czcionki lub rozmiaru tekstu

    • Aby zmienić wygląd tekstu, kliknij przycisk w obszarze Format tekstu.

    • Aby zmienić czcionkę lub rozmiar tekstu, kliknij inną czcionkę na liście Czcionka lub inny rozmiar na liście znajdującej się obok.

    Zmiana formatu liczby

    Po zmianie formatu liczby w komórce, zmienia się wartość wyświetlana, ale wartość przechowywana pozostaje niezmieniona. Na przykład, wartością przechowywaną odpowiadającą dacie 2000-6-22 jest kolejna liczba: 36 699. Nie zmienia się ona, nawet jeśli format liczby komórki zostanie zmieniony na Czwartek, 22 czerwca 2000.
    • W obszarze Format tekstu kliknij żądany format na liście Format liczby.

    Dodawanie obramowania wokół komórek

    • W obszarze Format komórki, obok pola Obramowanie, zaznacz żądany kolor, styl, szerokość i opcje położenia obramowania.

    Zmiana koloru tła komórek

    1. W obszarze Format komórki, obok pola Komórka kliknij strzałkę znajdującą się obok przycisku Kolor wypełnienia [image].
    2. Na palecie kolorów, kliknij żądany kolor.

    Wyrównywanie danych w komórce

    • Aby wyrównać tekst w poziomie, kliknij przycisk Wyrównaj do lewej Wyrównaj do lewej, Wyśrodkuj Wyśrodkuj lub Wyrównaj do prawej [image] .
    • Aby wyrównać tekst w pionie, kliknij przycisk Wyrównaj do góry [image], Wyrównaj do środka [image] lub Wyrównaj do dołu [image] .

    Uwaga Domyślnie tekst jest wyrównywany do lewej, a liczby, daty i godziny do prawej strony komórki.


Formaty liczby

Niektóre informacje podane w tym temacie mogą nie mieć zastosowania w przypadku niektórych języków.

W arkuszu kalkulacyjnym można zmieniać formaty liczb, używając okna dialogowego Polecenia i opcje zarówno w programie projektowym, jak i podczas wyświetlania w przeglądarce. Ustawienia w Panelu sterowania systemu Microsoft Windows określają również sposób wyświetlania formatów liczb, walut, dat i godzin. Na przykład, ustawienia określają, czy numer roku ma być wyświetlany za pomocą dwóch czy czterech cyfr. Informacje na temat formatów można znaleźć w Pomocy systemu Windows.

W programie Microsoft Visual Basic lub skrypcie można przypisać danym niestandardowe formaty liczby. W polu Format liczby można także wpisać niestandardowe formaty dostępne w modelu obiektowym arkusza kalkulacyjnego. Aby znaleźć więcej informacji, zobacz sposób uzyskiwania pomocy podczas programowania arkusza kalkulacyjnego.

Następujące formaty liczby są dostępne na liście Format liczby, na karcie Format w oknie dialogowym Polecenia i opcje.

Format | Efekty
Data ogólna | Wyświetla liczbę jako datę z opcjonalną godziną. Na przykład 31/8/99 05:54. Ułamkowa część liczby jest interpretowana jako godzina. Jeśli liczba nie ma części ułamkowej, wyświetlana jest wyłącznie data. Jeśli liczba ma wyłącznie część ułamkową, wyświetlana jest tylko godzina.
Data długa | Wyświetla datę zgodnie z ustawieniami regionalnymi systemu Windows dla formatu daty długiej. Na przykład Czwartek, 25 stycznia 2001.
Data średnia | Wyświetla datę zgodnie z ustawieniami regionalnymi miesięcy i separatora daty w systemie Windows, a rok wyświetla w postaci dwucyfrowej. Na przykład 25-sty-01.
Data krótka | Wyświetla datę zgodnie z ustawieniami regionalnymi systemu Windows dla formatu daty krótkiej. Na przykład 25/1/01.
Godzina długa | Wyświetla godzinę zgodnie z ustawieniami regionalnymi systemu Windows dla formatu godziny długiej. Na przykład 20:45:36.
Godzina średnia | Wyświetla godzinę w formacie 12-godzinnym ze znacznikiem AM lub PM z pominięciem sekund. Na przykład 8:45 PM.
Godzina krótka | Wyświetla godzinę w formacie 24-godzinnym, z pominięciem sekund. Na przykład 20:45.
Ogólny | Wyświetla liczbę wyrównaną do prawej, bez separatora tysięcy, poprzedzoną znakiem minus, jeśli liczba jest ujemna. Wyświetla maksymalnie 11 cyfr lub 10 cyfr z przecinkiem dziesiętnym, zaokrąglając dodatkowe cyfry po prawej stronie przecinka dziesiętnego. Wyświetla liczby zawierające więcej niż 11 cyfr po lewej stronie przecinka dziesiętnego w formacie naukowym. Wyświetla tekst wyrównany do lewej.
Format walutowy | Wyświetla liczbę zgodnie z ustawieniami regionalnymi systemu Windows dla waluty, z separatorem tysięcy, jeśli jest on potrzebny, i z dwoma miejscami po przecinku. Na przykład, zgodnie z domyślnymi ustawieniami regionalnymi dla języka polskiego, będzie to 2 532,75 zł.
Waluta euro | Wyświetla liczbę jako walutę euro, z separatorem tysięcy i dwoma miejscami po przecinku. Symbol euro jest umieszczany przed lub za liczbą, zgodnie z ustawieniami regionalnymi systemu Windows dla waluty. Na przykład, zgodnie z domyślnymi ustawieniami regionalnymi dla języka polskiego, będzie to 12,35 [image] .
Stałoprzecinkowy | Wyświetla liczbę z dwoma miejscami dziesiętnymi. Na przykład 68,30.
Standardowy | Wyświetla liczbę z separatorem tysięcy i z dwoma cyframi na prawo od przecinka dziesiętnego. Ustawienia regionalne systemu Windows dla liczb określają symbol używany jako separator tysięcy. Na przykład, jeśli separatorem tysięcy jest spacja, liczba wygląda następująco: 1 800,00.
Procentowy | Wyświetla liczbę pomnożoną przez 100, z dwoma miejscami dziesiętnymi i znakiem procentu. Na przykład wartość 0,8914 będzie wyświetlana jako 89,14 %.
Naukowy | Wyświetla liczbę w notacji wykładniczej. Na przykład 1,25E+10.
Tak/nie | Wyświetla wyraz Nie, jeśli liczba jest równa 0, a wyraz Tak dla wszystkich innych liczb.
Prawda/fałsz | Wyświetla wyraz Fałsz, jeśli liczba jest równa 0, a wyraz Prawda dla wszystkich innych liczb.
Wł/Wył | Wyświetla skrót Wył., jeśli liczba jest równa 0, a skrót Wł. dla wszystkich innych liczb.


Scalanie lub rozdzielanie komórek

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Zaznacz komórki, które chcesz scalić. Pamiętaj, że po scaleniu komórek zachowywane są dane jedynie z lewej górnej komórki zaznaczonego zakresu. Dane z pozostałych scalanych komórek są usuwane.
  3. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Format.
  4. W obszarze Format komórki kliknij przycisk Scal komórki [image] lub Rozdziel komórki Rozdziel komórki .


Zmiana szerokości kolumny

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Upewnij się, że nagłówki kolumn są wyświetlane.

    Jak?

    Nagłówki kolumn to litery w komórkach o kolorze szarym (lub innym, w zależności od ustawień ekranu systemu Microsoft Windows), znajdujących się u góry arkusza kalkulacyjnego, a nagłówki wierszy to liczby w komórkach o kolorze szarym, biegnących z boku arkusza kalkulacyjnego.

    1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
    2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Arkusz.
    3. W obszarze Pokazywanie/Ukrywanie zaznacz albo wyczyść pola wyboru Nagłówki kolumn lub Nagłówki wierszy.
  3. Zaznacz kolumny, które chcesz zmienić.
  4. Wskaż prawą granicę nagłówka kolumny lub zaznaczenia, tak aby wskaźnik zmienił się na Wskaźnik z prostopadłą strzałką z dwoma grotami.

  5. Przeciągnij granicę, aby uzyskać żądaną szerokość lub, chcąc dopasować szerokość kolumny do zawartości, kliknij dwukrotnie prawą granicę kolumny.


Zmiana wysokości wiersza

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Upewnij się, że numery wierszy są wyświetlane.

    Jak?

    Nagłówki kolumn to litery w komórkach o kolorze szarym (lub innym, w zależności od ustawień ekranu systemu Microsoft Windows), znajdujących się u góry arkusza kalkulacyjnego, a nagłówki wierszy to liczby w komórkach o kolorze szarym, biegnących z boku arkusza kalkulacyjnego.

    1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
    2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Arkusz.
    3. W obszarze Pokazywanie/Ukrywanie zaznacz albo wyczyść pola wyboru Nagłówki kolumn lub Nagłówki wierszy.
  3. Zaznacz wiersze, które chcesz zmienić.
  4. Wskaż dolną granicę nagłówka wiersza lub zaznaczenia, tak aby wskaźnik zmienił się na Wskaźnik z prostopadłą strzałką z dwoma grotami.

  5. Przeciągnij granicę, aby uzyskać żądaną wysokość wiersza albo zaznaczenia lub, chcąc dopasować wysokość wiersza do zawartości, kliknij dwukrotnie dolną granicę wiersza.


Wyświetlanie tekstu lub arkusza kalkulacyjnego, tak aby był czytany od prawej do lewej albo od lewej do prawej

Używanie kierunku tekstu lub wyświetlania od prawej do lewej w przypadku wyświetlania arkusza w językach, w których czyta się od prawej do lewej.

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Wykonaj jedną z następujących czynności:

    Wyświetlanie całego arkusza od prawej do lewej lub od lewej do prawej

    1. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Arkusz.
    2. W obszarze Pokazywanie/Ukrywanie zaznacz lub wyczyść pole wyboru Wyświetl od prawej do lewej.

    Po wybraniu opcji wyświetlania od prawej do lewej, elementy arkusza są wyświetlane jak lustrzane odbicie domyślnego trybu wyświetlania od lewej do prawej: Numery wierszy są wyświetlane po prawej stronie, a paski przewijania pionowego po lewej stronie arkusza.

    Wyświetlanie tekstu od prawej do lewej lub od lewej do prawej

    Kierunek tekstu jest domyślnie dopasowywany do Kontekstu, czyli tekst jest automatycznie wyświetlany w kierunku od lewej do prawej lub od prawej do lewej strony w zależności od użytego języka. W niektórych komórkach można określić kierunek tekstu od prawej do lewej lub od lewej do prawej, aby podczas pracy z kilkoma językami w różnych komórkach, poszczególne komórki zachowywały pożądany kierunek tekstu.

    1. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Format.
    2. W obszarze Format tekstu kliknij strzałkę obok pola Kierunek tekstu i wybierz żądaną opcję z listy.


Znajdowanie danych — informacje

Funkcja Znajdź (w oknie dialogowym Polecenia i opcje, na karcie Arkusz) pozwala zlokalizować tekst, liczby, daty i godziny, które zostały wprowadzone bezpośrednio w komórkach lub stanowią wyniki formuł.

Używając opcji Znajdź, należy pamiętać o następujących wskazówkach:

  • Uwzględnianie wielkości liter Domyślnie funkcja Znajdź nie uwzględnia wielkości liter. Aby znaleźć tylko te komórki, które zawierają wartości odpowiadające wielkością liter wprowadzonemu wpisowi, należy zaznaczyć pole wyboru Uwzględnij wielkość liter.
  • Tylko cała komórka Domyślnie funkcja Znajdź wyszukuje komórki zawierające wartość wprowadzoną w polu Znajdowanie. Na przykład, wpis „Jan” spowoduje znalezienie komórek z takimi ciągami, jak „Janek” czy „Jankowski”. Aby znaleźć komórki zawierające jedynie wprowadzoną wartość, należy zaznaczyć pole wyboru Tylko cała komórka.
  • Wartości formatowane Funkcja Znajdź wyszukuje wyświetlane wartości, a nie formaty. Na przykład, jeśli komórka ma format liczby typu Tak/Nie i zawiera wartość zero (0), to będzie w niej wyświetlany wyraz Nie i polecenia Znajdź można użyć do znalezienia frazy „Nie”. Polecenia Znajdź nie można używać do znajdowania komórek formatowanych za pomocą określonego koloru lub czcionki.
  • Kierunek wyszukiwania Funkcja Znajdź przeszukuje tekst od lewej do prawej w kolejnych kolumnach pierwszego wiersza, następnie od lewej do prawej w kolejnych kolumnach drugiego wiersza i tak dalej.
  • Symbole wieloznaczne Funkcja Znajdź nie pozwala na użycie symboli wieloznacznych, takich jak znak zapytania (?) i gwiazdka (*).
  • Dane ukryte Funkcja Znajdź nie znajduje danych w komórkach ukrytych lub takich, które zostały ukryte w wyniku filtrowania.


Znajdowanie danych

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.

  2. Aby przeszukać cały arkusz kalkulacyjny, kliknij pojedynczą komórkę. Aby przeszukać określony zakres komórek, zaznacz ten zakres.

  3. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Arkusz.
  4. W polu Znajdowanie wpisz tekst lub wartość, które chcesz znaleźć.

    Uwagi

    • Domyślnie funkcja Znajdź wyszukuje komórki zawierające wartość wprowadzoną w polu Znajdowanie. Na przykład, wpis „Jan” spowoduje znalezienie komórek z takimi ciągami, jak „Janek” czy „Jankowski”. Aby znaleźć komórki zawierające jedynie wprowadzoną wartość, należy zaznaczyć pole wyboru Tylko cała komórka.
    • Domyślnie funkcja Znajdź nie uwzględnia wielkości liter. Aby znaleźć tylko te komórki, które zawierają wartości odpowiadające wielkością liter wprowadzonemu wpisowi, należy zaznaczyć pole wyboru Uwzględnij wielkość liter.
  5. Kliknij przycisk Znajdź następny.


Sortowanie danych

Dane przeznaczone do sortowania powinny mieć formę listy. Lista ma podobne elementy w każdej kolumnie, ma etykiety kolumn w pierwszym wierszu i nie zawiera pustych wierszy lub kolumn.

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Wykonaj jedną z następujących czynności:

    Sortowanie według jednej kolumny

    1. Aby posortować całą listę, kliknij komórkę na tej liście. Etykiety kolumn nie są sortowane.

      Aby posortować część listy, zaznacz zakres do sortowania. Aby nie sortować etykiet kolumn z pozostałą częścią zakresu, nie zaznaczaj etykiet kolumn jako części zakresu.

    2. Kliknij strzałkę znajdującą się obok przycisku Sortuj rosnąco [image] lub Sortuj malejąco [image] na pasku narzędzi, a następnie kliknij kolumnę, według której chcesz sortować.

    Uwagi

    • Nie są sortowane wiersze ukryte podczas filtrowania lub takie, których wysokość została ustawiona na zero.
    • Można sortować tylko wiersze. Nie można sortować kolejności kolumn.
    • Sortowanie nie uwzględnia wielkich i małych liter. Na przykład, w przypadku sortowania rosnącego „BIAŁY” i „biały” zostaną umieszczone przed „CZARNY” i „czarny”.

    Sortowanie według kilku kolumn

    Aby wykonać sortowanie według kilku kolumn, można posortować listę kilkukrotnie, za każdym razem według innej kolumny. Na przykład poniższa lista jest zorganizowana według sprzedawcy. Lista została posortowana najpierw według kolumny Produkt (zwanej także kolumną wewnętrzną lub kolumną niższej kategorii), tak aby produkty zostały ułożone w porządku alfabetycznym; następnie lista została posortowana według kolumny Sprzedawca (zwanej także kolumną zewnętrzną lub kolumną wyższej kategorii).

    Przykład danych posortowanych według dwóch kolumn

    1. Najpierw określ kolejność kategoryzacji. Na przykład, jeśli sortujesz dwie kolumny, określ, która kolumna jest ważniejsza, a która mniej ważna.

    2. Zaznacz komórkę w kolumnie niższej kategorii (wewnętrznej).

    3. Kliknij strzałkę znajdującą się obok przycisku Sortuj rosnąco [image] lub Sortuj malejąco [image] na pasku narzędzi, a następnie kliknij kolumnę, według której chcesz sortować.

    4. Zaznacz komórkę w kolumnie wyższej kategorii (zewnętrznej) i powtórz powyższy krok.

    5. Powtórz te kroki dla kolejnych kolumn wyższych kategorii (zewnętrznych) do momentu uporządkowania danych w żądany sposób.

    Uwagi

    • Nie są sortowane wiersze ukryte podczas filtrowania lub takie, których wysokość została ustawiona na zero.
    • Można sortować tylko wiersze. Nie można sortować kolejności kolumn.
    • Sortowanie nie uwzględnia wielkich i małych liter. Na przykład, w przypadku sortowania rosnącego „BIAŁY” i „biały” zostaną umieszczone przed „CZARNY” i „czarny”.


Stosowanie lub usuwanie filtru

Stosowanie filtru

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Kliknij komórkę w obrębie listy, którą chcesz filtrować lub zaznacz określony zakres komórek, które chcesz filtrować.
  3. Na pasku narzędzi kliknij przycisk Autofiltr [image], aby go zaznaczyć.
  4. Kliknij strzałkę w kolumnie zawierającej dane, które chcesz wyświetlić.

  5. Aby wyświetlić tylko te elementy, które chcesz, aby były widoczne, wyczyść pole wyboru Wszystkie, a następnie zaznacz pole wyboru dla każdego elementu, który chcesz wyświetlić.

Usuwanie filtru

  • Na pasku narzędzi kliknij przycisk Autofiltr [image], aby przestał być zaznaczony.


Sumowanie filtrowanych danych

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Przefiltruj dane, aby wyświetlić wiersze, które chcesz zsumować.

    Jak?

    Stosowanie filtru

    1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
    2. Kliknij komórkę w obrębie listy, którą chcesz filtrować lub zaznacz określony zakres komórek, które chcesz filtrować.
    3. Na pasku narzędzi kliknij przycisk Autofiltr [image], aby go zaznaczyć.
    4. Kliknij strzałkę w kolumnie zawierającej dane, które chcesz wyświetlić.

    5. Aby wyświetlić tylko te elementy, które chcesz, aby były widoczne, wyczyść pole wyboru Wszystkie, a następnie zaznacz pole wyboru dla każdego elementu, który chcesz wyświetlić.

    Usuwanie filtru

    • Na pasku narzędzi kliknij przycisk Autofiltr [image], aby przestał być zaznaczony.

  3. Kliknij komórkę znajdującą się pod danymi, które chcesz zsumować.
  4. Kliknij przycisk Autosumowanie [image] na pasku narzędzi, a następnie naciśnij klawisz ENTER.

Uwaga Przycisk Autosumowanie powoduje zsumowanie tylko danych w widocznych wierszach. Aby uwzględnić w sumie wszystkie wiersze, należy je najpierw wyświetlić, a następnie zsumować.


Arkusze kalkulacyjne publikowane za pomocą programu Excel — informacje

Gdy arkusz kalkulacyjny jest publikowany za pomocą programu Microsoft Excel, można otworzyć stronę sieci Web i zmodyfikować projekt w programie Microsoft FrontPage lub w widoku projektu strony dostępu do danych w programie Microsoft Access. Można również otworzyć arkusz programu Excel (plik xls), jeżeli został zapisany, dokonać zmian i ponowne opublikować arkusz kalkulacyjny na tej samej stronie sieci Web. Jeżeli arkusz programu Excel nie został zapisany, projektant może eksportować arkusz kalkulacyjny do programu Microsoft Excel, dokonać zmian i albo zapisać kopię, albo opublikować zmieniony arkusz kalkulacyjny.

Podczas publikowania arkusza kalkulacyjnego za pomocą programu Microsoft Excel większość funkcji programu Excel jest zachowywana i działa tak jak w programie Excel. Funkcje z poniższej listy działają inaczej lub nie są zachowywane podczas publikowania lub zapisywania arkusza kalkulacyjnego na stronie sieci Web.

Formuły, funkcje i obliczenia programu Excel | Co się dzieje podczas publikowania lub zapisywania jako strony sieci Web
Etykiety w formułach | Etykiety są konwertowane na odwołania do komórek.
Odwołania do danych w innych arkuszach | Odwołania są konwertowane na wartości.
Sumy częściowe | Liczby i obliczenia są wyświetlane poprawnie. Funkcje grup i konspektu nie są zachowywane.
System daty 1904 | Wyświetlane daty pozostają bez zmian, ale liczby kolejne dat są konwertowane na system daty 1900.
Dokładność jak wyświetlono | Publikowana jest wartość komórki.
Styl odwołań W1K1 | Styl odwołań W1K1 jest konwertowany na styl odwołań A1.

Funkcje formatowania, grafiki i wyświetlania programu Excel | Co się dzieje podczas publikowania lub zapisywania jako strony sieci Web
Tekst obrócony lub pionowy | Tekst obrócony lub pionowy jest konwertowany na tekst poziomy.
Wyrównanie rozłożone | Niezachowywane.
Wyrównanie tajlandzkie | Niezachowywane.
Wcięty tekst | Niezachowywany.
Zawinięty tekst w komórkach | Niezachowywany.
Grafika | Niezachowywana.
Wypełnienia deseniami | Niezachowywane.
Kropkowane lub przerywane obramowania | Kropkowane lub przerywane obramowania są konwertowane na pełne obramowania.
Wiele czcionek w jednej komórce | Niezachowywane. Używana jest czcionka pierwszego znaku w komórce.
Formatowanie warunkowe | Niezachowywane.
Komentarze komórki | Niezachowywane.
Ograniczenia i komunikaty sprawdzania poprawności danych | Niezachowywane.
Strzałki śledzenia inspekcji | Niezachowywane.
Tworzenie konspektu | Zwinięte wiersze są publikowana jako ukryte. Rozwinięte wiersze są publikowane normalnie.
Funkcje drukowania lub ustawienia strony | Niezachowywane.

Funkcje plików, udostępniania i importowania programu Excel | Co się dzieje podczas publikowania lub zapisywania jako strony sieci Web
Informacje skoroszytu udostępnionego | Niezachowywane.
Zgodność z programem Lotus | Styl odwołań W1K1 jest konwertowany na styl odwołań A1.
Zakresy danych zewnętrznych | Wartości są publikowane. Możliwość odświeżania na podstawie danych źródłowych nie jest zachowywana.
Kwerendy sieci Web | Wartości są publikowane. Możliwość odświeżania na podstawie danych źródłowych nie jest zachowywana.
Hasła | Aby opublikować arkusz chroniony, należy użyć pustego hasła lub zrezygnować z hasła.


Pobieranie danych z innych źródeł

Kopiowanie i wklejanie danych z innego programu

Dane pochodzące z innych źródeł, takich jak plik tekstowy, arkusz programu Microsoft Excel lub dokument programu Microsoft Word można skopiować do Schowka, a następnie wkleić do arkusza kalkulacyjnego.

  1. W aplikacji, z której chcesz kopiować, zaznacz dane do skopiowania i kliknij przycisk Kopiuj [image] lub, jeśli nie ma takiego przycisku, naciśnij klawisze CTRL+C.

  2. W arkuszu kalkulacyjnym zaznacz górną lewą komórkę obszaru, w którym chcesz wkleić dane.

    Wklejone dane zastąpią dane istniejące. Aby zapobiec utracie danych, upewnij się, że obszar, w którym będą wklejane dane, jest pusty lub przenieś istniejące dane do innego miejsca w skoroszycie.

  3. Na pasku narzędzi kliknij przycisk Wklej [image].

Importowanie danych ze strony sieci Web, pliku tekstowego lub pliku XML

Aby osiągnąć najlepsze rezultaty, należy umieścić dane importowane ze strony sieci Web lub pliku tekstowego w tabeli HTML. Muszą się one znajdować na tym samym serwerze sieci Web lub komputerze, na którym znajduje się arkusz kalkulacyjny. Na przykład jeśli stronę sieci Web zawierającą arkusz kalkulacyjny otwarto na serwerze sieci Web, to można importować wyłącznie dane znajdujące się na tym serwerze.

Uwaga Dane są zawsze importowane od komórki A1 arkusza kalkulacyjnego. Istniejące dane zostaną zastąpione bez ostrzeżenia.

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Importuj.
  3. Na liście Typ danych zaznacz typ pliku, który chcesz importować: XML, HTML lub CSV.
  4. W polu Adres URL wpisz adres lub ścieżkę strony sieci Web, pliku tekstowego lub pliku XML, który chcesz importować albo kliknij przycisk Przeglądaj przycisk Plik, aby zlokalizować plik.
  5. Kliknij przycisk Importuj teraz.

    Jeśli każdorazowe otwarcie arkusza kalkulacyjnego w przeglądarce ma powodować jego aktualizację o najnowsze dane ze strony sieci Web, pliku tekstowego lub pliku XML, zaznacz pole wyboru Odśwież dane z adresu URL w czasie działania.

Uwagi

  • Nie można użyć tej metody do importowania obrazów lub formantów.
  • Polecenie to działa wyłącznie w programie do projektowania i w czasie działania nie może być uruchomione w przeglądarce.
  • Po wybraniu importowania danych XML będą importowane wyłącznie dane w formacie arkusza kalkulacyjnego XML.

Tworzenie formuły do pobierania danych

W komórce arkusza kalkulacyjnego można pobierać dane, korzystając z jednej z funkcji OBIEKT. Na przykład można użyć funkcji UTWÓRZ.OBIEKT, aby utworzyć wystąpienie obiektu, który będzie się znajdował na serwerze zdalnym, a następnie zastosować funkcję OBIEKT, aby pobrać dane z tego obiektu. Można także użyć funkcji HOST, aby pobrać dane z aplikacji obsługującej arkusz kalkulacyjny. Na przykład poniższa formuła służy do pobierania danych z pola tekstowego znajdującego się na tej samej stronie sieci Web, co arkusz kalkulacyjny:

=HOST().PoleTekst1.Wartość

Aby uzyskać więcej informacji, zapoznaj się z tematami Pomocy dotyczącymi funkcji UTWÓRZ.OBIEKT, OBIEKT, HOST lub XMLDOM.

Ustanawianie połączenia ze źródłem danych

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest uaktywniony. Aby uzyskać instrukcje, zobacz Pomoc programu do projektowania.
  2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Źródło danych.

  3. Wykonaj jedną z następujących czynności:

    Połącz składnik Arkusz kalkulacyjny ze źródłem danych znajdującym się na tej samej stronie sieci Web

    • Na liście Źródło danych w obszarze Połączenie z danymi skoroszytu wybierz źródło danych. Jeśli na stronie sieci Web nie ma źródeł danych, to powyższa opcja jest niedostępna.

      Aby połączyć aktywny arkusz z pojedynczym elementem znajdującym się w źródle danych określonym dla skoroszytu (takim jak tabela, kwerenda itd.), w obszarze Połączenie danych arkusza zaznacz opcję Członek danych w źródle danych skoroszytu, a następnie zaznacz członek danych na liście.

    Porada

    Jeśli użytkownik korzysta ze strony dostępu do danych i nie utworzył arkusza kalkulacyjnego, to można przeciągnąć tabelę lub inny członek danych z listy pola programu Microsoft Access na stronę dostępu do danych, a następnie postępować zgodnie z instrukcjami Kreatora układu, aby utworzyć arkusz kalkulacyjny połączony z tabelą lub innym elementem przeciągniętym na stronę.

    Połącz aktywny arkusz i źródło danych

    1. W obszarze Połączenie danych arkusza zaznacz opcję Źródło danych arkusza.

    2. Aby ustanowić połączenie ze źródłem danych, z którego chcesz korzystać, w polu Połączenie wpisz ciąg połączenia dla źródła danych lub kliknij przycisk Edycja i postępuj zgodnie z instrukcjami wyświetlanymi w oknie dialogowym.
    3. Jeśli to konieczne, w polu Tekst polecenia lub SQL wpisz tekst polecenia lub ciąg SQL, aby pobrać dane ze źródła danych.


Eksportowanie arkusza kalkulacyjnego do skoroszytu programu Excel

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Na pasku narzędzi arkusza kalkulacyjnego kliknij przycisk Eksportuj do programu Microsoft Excel [image], aby uruchomić program Microsoft Excel lub przełączyć się do niego i wyświetlić dane w skoroszycie.

Uwagi

  • Ponieważ program Excel obsługuje 256 kolumn i 65 536 wierszy, dane w kolumnach od IW do ZZZ oraz wierszach od 65 537 do 262 144 nie są eksportowane z arkusza kalkulacyjnego. Można je jednak skopiować do kilku arkuszy programu Excel.
  • Podczas eksportu danych z arkusza kalkulacyjnego do programu Excel, eksportowane są tylko wartości i formuły. W programie Excel nie są zachowywane łącza do innych danych na stronie sieci Web lub innych stron sieci Web.
  • W przypadku eksportowania niektórych formatów liczby arkusza kalkulacyjnego, w programie Excel dane są wyświetlane za pomocą niestandardowego formatu liczby. Na przykład, formaty arkusza kalkulacyjnego typu Tak/Nie, Prawda/Fałsz i Wł/Wył w programie Excel są wyświetlane w niestandardowym formacie liczb. Informacje o niestandardowych formatach liczb w programie Excel można znaleźć w Pomocy programu Excel.


Rozwiązywanie problemów z arkuszami kalkulacyjnymi

Wprowadzanie i edytowanie danych i formuł

Nie mogę zmienić komórek w arkuszu kalkulacyjnym

Komórki mogą być zablokowane i chronione. Podczas projektowania można odblokować arkusz kalkulacyjny i/lub usunąć jego ochronę.

Jak?

Tę procedurę można wykonać tylko w czasie projektowania. Użytkownicy nie mają dostępu do tej opcji w przeglądarce.

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Ochrona.
  3. W obszarze Arkusz wyczyść pole wyboru Chroń aktywny arkusz.
  4. Aby użytkownicy mogli wstawiać i usuwać arkusze oraz zmieniać ich nazwy lub używać okna dialogowego Polecenia i opcje, sprawdź, czy w obszarze Skoroszyt zaznaczone są pola wyboru Wstawianie, usuwanie lub zmiana nazw arkuszy oraz Okno dialogowe Polecenia i opcje.

Nie mogę zawinąć tekstu w komórkach arkusza kalkulacyjnego

Zawinięty tekst w komórkach nie jest obsługiwany w składniku Arkusz kalkulacyjny Microsoft Office. Jeśli arkusz kalkulacyjny zawierający zawinięty tekst opublikowano z programu Microsoft Excel, to tekst będzie pojawiał się w jednym wierszu. Aby tekst był wyświetlany prawidłowo, można go skrócić, użyć dla niego kilku komórek lub tak poszerzyć kolumnę, aby widoczny był cały tekst.

W arkuszu kalkulacyjnym nie ma paska formuły

W przeciwieństwie do programu Microsoft Excel składnik Arkusz kalkulacyjny Microsoft Office nie udostępnia paska formuły, w którym można edytować zawartość komórek. Można jednak edytować zawartość komórki, klikając ją dwukrotnie lub zaznaczając komórkę i naciskając klawisz F2.

Nie mogę ustawić hasła dla arkusza kalkulacyjnego

Dla arkusza kalkulacyjnego nie można ustawić hasła. W zależności od miejsca opublikowania strony sieci Web może istnieć możliwość ustawienia hasła wymaganego do otwarcia strony, na której znajduje się arkusz kalkulacyjny. Na przykład może być możliwe ustawienie hasła dla uprawnień dostępu na serwerze sieci Web. Aby uzyskać więcej informacji, skontaktuj się z administratorem witryny sieci Web.

Nie mogę zmienić hiperłącza opublikowanego z programu Microsoft Excel

Ponownie wprowadź hiperłącze W przypadku modyfikowania hiperłącza opublikowanego z arkusza kalkulacyjnego programu Excel i utworzonego za pomocą okna dialogowego Wstaw hiperłącze tego programu można zmienić tekst hiperłącza, ale nie można zmienić adresu, do którego ono prowadzi. Aby zmienić adres, należy usunąć hiperłącze, a następnie wstawić nowe hiperłącze.

Zmień adres w programie Excel i opublikuj ponownie W oryginalnym arkuszu programu Excel można zmodyfikować zarówno wyświetlany tekst, jak i adres hiperłącza. Dane można następnie ponownie opublikować w sieci Web. Aby uzyskać więcej informacji, zobacz Pomoc programu Excel.

Nie mogę kontrolować rozmiaru arkusza kalkulacyjnego

Arkusz kalkulacyjny może być tak ustawiony, aby automatycznie dobierał swój rozmiar. Jeśli na karcie Zaawansowane, w oknie dialogowym Polecenia i opcje zaznaczono pole wyboru Autodopasowanie arkusza kalkulacyjnego, to podczas wstawiania lub usuwania wierszy i kolumn oraz zmiany wysokości wierszy i szerokości kolumn arkusz kalkulacyjny znajdujący się na stronie sieci Web odpowiednio zwiększa lub zmniejsza swój rozmiar. Arkusze kalkulacyjne publikowane z programu Microsoft Excel mają domyślnie włączoną opcję automatycznej zmiany rozmiaru. Podczas projektowania można określić, czy funkcja automatycznej zmiany rozmiaru ma być włączona, czy wyłączona.

Jak?

Po ustawieniu arkusza kalkulacyjnego na rozmiar wyświetlanego zakresu i włączeniu opcji automatycznej zmiany rozmiaru, arkusz kalkulacyjny jest powiększany lub pomniejszany na stronie sieci Web w zależności od treści. Rozmiar arkusza kalkulacyjnego zmienia się w miarę wstawiania lub usuwania wierszy i kolumn albo w przypadku zmiany wysokości wierszy lub szerokości kolumn.

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Zaawansowane.
  3. Zaznacz lub wyczyść pole wyboru Autodopasowanie arkusza kalkulacyjnego.

    Aby ograniczyć powiększanie arkusza kalkulacyjnego do określonego rozmiaru, wpisz wartość — w pikselach lub procentowo w odniesieniu do całej strony sieci Web — w jednym lub obu polach Maksymalna wysokość i Maksymalna szerokość. Na przykład, aby zezwolić na powiększanie arkusza do połowy szerokości strony sieci Web, wpisz wartość 50 % w polu Maksymalna szerokość. Aby ograniczyć szerokość arkusza do 300 pikseli, wpisz wartość 300 w polu Maksymalna szerokość.

Nie mogę kontrolować wyświetlania lub ukrywania pasków przewijania w arkuszu kalkulacyjnym

Jeśli arkusz kalkulacyjny jest tak skonfigurowany, aby automatycznie zmieniał rozmiar (tzn. w oknie dialogowym Polecenia i opcje, na karcie Zaawansowane zaznaczono pole wyboru Autodopasowanie arkusza kalkulacyjnego), to po osiągnięciu przez niego maksymalnej wysokości lub szerokości określonej w oknie dialogowym Polecenia i opcje pojawiają się paski narzędzi, niezależnie od ustawień wskazujących, że mają być one wyświetlone lub ukryte. Aby kontrolować sposób wyświetlania pasków przewijania, należy wyłączyć funkcję automatycznej zmiany rozmiaru.

Jak?

Po ustawieniu arkusza kalkulacyjnego na rozmiar wyświetlanego zakresu i włączeniu opcji automatycznej zmiany rozmiaru, arkusz kalkulacyjny jest powiększany lub pomniejszany na stronie sieci Web w zależności od treści. Rozmiar arkusza kalkulacyjnego zmienia się w miarę wstawiania lub usuwania wierszy i kolumn albo w przypadku zmiany wysokości wierszy lub szerokości kolumn.

  1. W oknie projektu upewnij się, że arkusz kalkulacyjny jest aktywny. Aby uzyskać instrukcje, zobacz Pomoc programu projektowego.
  2. Na pasku narzędzi kliknij przycisk Polecenia i opcje [image], a następnie kliknij kartę Zaawansowane.
  3. Zaznacz lub wyczyść pole wyboru Autodopasowanie arkusza kalkulacyjnego.

    Aby ograniczyć powiększanie arkusza kalkulacyjnego do określonego rozmiaru, wpisz wartość — w pikselach lub procentowo w odniesieniu do całej strony sieci Web — w jednym lub obu polach Maksymalna wysokość i Maksymalna szerokość. Na przykład, aby zezwolić na powiększanie arkusza do połowy szerokości strony sieci Web, wpisz wartość 50 % w polu Maksymalna szerokość. Aby ograniczyć szerokość arkusza do 300 pikseli, wpisz wartość 300 w polu Maksymalna szerokość.

Filtrowanie, sortowanie i wyszukiwanie danych

Dane w arkuszu kalkulacyjnym nie są prawidłowo sortowane

Jeśli sortowanie arkusza kalkulacyjnego nie przynosi oczekiwanych wyników, wykonaj następujące czynności:

Sprawdź zaznaczenie przed sortowaniem Po zaznaczeniu zakresu komórek do posortowania arkusz kalkulacyjny sortuje całą zawartość zakresu i tylko ten zakres. Oznacza to, że zaznaczony wiersz nagłówka również będzie sortowany. Oznacza to również, że po zaznaczeniu pojedynczej kolumny danych na liście przeznaczonej do posortowania sortowana będzie wyłącznie ta kolumna, a nie cała lista. Należy spróbować zaznaczyć pojedynczą komórkę w zakresie, który ma być posortowany, ale nie komórkę w wierszu nagłówka. Arkusz kalkulacyjny automatycznie wykryje dane do sortowania i wykluczy wiersz nagłówka. Jeśli powyższa metoda nie będzie działać prawidłowo w przypadku sortowanych danych, należy zaznaczyć cały zakres przeznaczony do posortowania, bez zaznaczania wiersza nagłówka.

Sprawdź, czy liczby są w formacie numerycznym Jeśli wartość nie jest posortowana we właściwej kolejności, to być może komórka została sformatowana jako tekst, a nie jako liczba. Na przykład w niektórych systemach księgowych podczas importowania danych do arkusza kalkulacyjnego liczby ujemne są konwertowane na tekst. Aby zastosować prawidłowe formatowanie, należy kliknąć komórkę, a następnie zmienić format liczby.

Sprawdź, czy daty i godziny są prawidłowo sformatowane Daty i godziny są traktowane jako liczby. Podczas wpisywania daty lub godziny format komórki zmienia się z ogólnego formatu liczb na wbudowany format daty lub czasu. Aby daty i godziny były sortowane prawidłowo, wszystkie daty i godziny w kolumnie muszą mieć taki sam format daty lub czasu. Aby zastosować prawidłowe formatowanie, należy kliknąć komórkę, a następnie zmienić format liczby.

Usuń wszystkie niepotrzebne spacje Upewnij się, że dane nie są poprzedzone spacjami. Usuń wszystkie spacje wiodące przed rozpoczęciem sortowania danych.

Sprawdź ustawienia regionalne Kolejności sortowania różnią się w zależności od ustawień regionalnych. Upewnij się, że ustawienie regionalne w oknach Ustawienia regionalne lub Opcje regionalne w Panelu sterowania są prawidłowe. Aby uzyskać informacje dotyczące zmieniania ustawień regionalnych, zapoznaj się z Pomocą systemu Windows.

Upewnij się, że sortowanie kilku kolumn odbywa się w prawidłowej kolejności Jeśli sortowanych jest kilka kolumn, to kolejność sortowania określa sposób organizowania danych. Najpierw należy sortować kategorie niższego poziomu (wewnętrzne), a następnie kategorie wyższego poziomu (zewnętrzne).

Na liście w arkuszu kalkulacyjnym nie pojawiają się wszystkie dane

Być może lista została przefiltrowana za pomocą polecenia Autofiltr w celu wyświetlenia określonych wierszy. Jeśli z prawej strony górnej komórki każdej kolumny widoczna jest strzałka, wykonaj jedną z następujących czynności:

  • Kliknij strzałkę, a następnie kliknij opcję Pokaż wszystko.
  • Upewnij się, że na pasku narzędzi nie jest wciśnięty przycisk Autofiltr [image].

Nie mogę filtrować arkusza kalkulacyjnego, w którym znajdują się scalone komórki

Składnik Arkusz kalkulacyjny Microsoft Office nie obsługuje funkcji filtrowania list zawierających scalone komórki. Jeśli arkusz kalkulacyjny zawiera scalone komórki, to należy je rozdzielić, a następnie ponownie spróbować użyć polecenia Autofiltr.

Polecenie Znajdź następny nie powoduje odnalezienia danych w arkuszu kalkulacyjnym

Po zaznaczeniu zakresu danych polecenie Znajdź następny wyszukuje określone wartości tylko w zaznaczeniu. Aby znaleźć dane znajdujące się w dowolnym miejscu arkusza kalkulacyjnego, przed kliknięciem polecenia Znajdź następny należy zaznaczyć pojedynczą komórkę.

Po opublikowaniu arkusza kalkulacyjnego z programu Excel lista rozwijana Autofiltr zawiera błędy

W programie Microsoft Excel można utworzyć kryteria Autofiltru, których nie można wyświetlać na liście rozwijanej Autofiltr arkusza kalkulacyjnego. Na przykład brakuje odpowiedników dla kryteriów arkusza kalkulacyjnego „10 pierwszych...” lub „zaczyna się od”.

Podczas publikowania w programie Excel zakresu Autofiltru wykorzystującego kryteria, których nie można wyświetlić na liście Autofiltr, filtrowane elementy są poprawnie wyświetlane na stronie sieci Web, ale zawartość listy Autofiltr nie odzwierciedla wybranych kryteriów.

Listę rozwijaną można zresetować, klikając na pasku narzędzi arkusza kalkulacyjnego przycisk Autofiltr [image], aby wyłączyć filtr, a następnie ponowne klikając przycisk Autofiltr [image], aby włączyć filtr. Spowoduje to również zresetowanie wyświetlonej listy.

Importowanie i eksportowanie

Nie mogę opublikować z programu Microsoft Excel arkusza kalkulacyjnego, który jest chroniony hasłem

Z programu Microsoft Excel można publikować arkusz kalkulacyjny chroniony hasłem, tylko używając pustego hasła. Należy otworzyć oryginalny skoroszyt w programie Excel, usunąć hasło i ponownie spróbować opublikować arkusz kalkulacyjny.

Eksport filtru arkusza kalkulacyjnego do programu Excel nie przebiega poprawnie

W arkuszu kalkulacyjnym można utworzyć kryteria Autofiltru, których nie można wyświetlać na liście rozwijanej Autofiltr lub w oknie dialogowym Autofiltr niestandardowy programu Microsoft Excel. Na przykład w programie Excel brakuje bezpośredniego odpowiednika filtru arkusza kalkulacyjnego zawierającego trzy niezaznaczone elementy. Po wyeksportowaniu do programu Excel arkusza kalkulacyjnego zawierającego nieobsługiwane kryteria filtrowania w programie tym wyświetlany jest cały zakres Autofiltru.

Aby wyeksportować przefiltrowane dane i wyświetlić je tak samo, jak w arkuszu kalkulacyjnym, zalecane jest określenie dla każdego filtru nie więcej niż dwóch zestawów kryteriów. Oznacza to, że nie mogą istnieć więcej niż dwa pola wyboru o ustawieniach (zaznaczone lub wyczyszczone) innych niż w przypadku pozostałych pól wyboru.

Pojawia się komunikat informujący o zbyt dużej liczbie wierszy lub kolumn podczas próby eksportowania arkusza kalkulacyjnego do programu Excel

Arkusz kalkulacyjny może zawierać dane w kolumnach od A do ZZZ i wierszach od 1 do 262 144. W programie Microsoft Excel dane mogą zajmować tylko kolumny od A do IV i wiersze od 1 do 65 536. Aby wyeksportować arkusz kalkulacyjny do programu Excel, należy usunąć lub przenieść dane z kolumn dalszych niż IV i wierszy dalszych niż 65 536. Dane z takich kolumn i wierszy można skopiować do dodatkowego arkusza kalkulacyjnego programu Excel.

Praca z arkuszem kalkulacyjnym w przeglądarce

Użytkownicy nie mogą interakcyjnie pracować z arkuszem kalkulacyjnym po otwarciu go w przeglądarce

Użytkownicy, którzy mogą wyświetlić arkusz kalkulacyjny, ale nie mają możliwości interakcji, być może nie mają dostępu do licencji Microsoft Office XP. Należy się upewnić, że użytkownicy korzystają z prawidłowej licencji.

Po otwarciu strony sieci Web zawierającej arkusz kalkulacyjny w przeglądarce wyświetla się błąd „Nie można otworzyć adresu URL."

Strona sieci Web danych źródłowych jest niedostępna Jeśli niektóre dane w arkuszu kalkulacyjnym pochodzą z innej strony sieci Web, to należy się upewnić, że strona sieci Web jest dostępna oraz że projektant i docelowi użytkownicy mają do niej prawidłowy dostęp.

Strona sieci Web nie jest lokalna Jeśli arkusz kalkulacyjny zawiera formułę połączoną z danymi na innej stronie sieci Web, to druga strona musi znajdować się na komputerze lokalnym lub w sieci intranet, a projektant musi mieć do niej prawidłowy dostęp.

Kliknięcie przycisku Edytuj w przeglądarce sieci Web otwiera stronę sieci Web w niewłaściwym programie

Programy dostępne w przeglądarce sieci Web po kliknięciu przycisku Edytuj zależą do sposobu opublikowania strony.

Jeśli kliknięcie przycisku Edytuj w przeglądarce sieci Web otwiera niewłaściwy program, to należy go zamknąć, uruchomić żądany program, a następnie otworzyć w nim stronę sieci Web.

Wartości błędów

Zamiast wyników formuł widzę wartości błędów

Jeśli nie można obliczyć części formuły lub wystąpił problem dotyczący formuły, formuła zwraca wartość błędu, taką jak #NAZWA? lub #DZIEL/0!. Aby ustalić przyczynę, należy zapoznać się z tematami dotyczącymi rozwiązywania problemów z wartościami błędów.


Rozwiązywanie problemów z wartościami błędów w arkuszu kalkulacyjnym

Jeśli formuła nie może prawidłowo obliczyć wyniku, arkusz kalkulacyjny wyświetla wartość błędu. Na przykład wartości błędów mogą być wyświetlane, jeśli formuła oczekuje wartości numerycznej, a odnajduje tekst, jeśli komórka, do której odwołuje się formuła, została usunięta albo komórka nie jest dostatecznie szeroka, aby wyświetlić wynik.

Nie zawsze przyczyną generowania wartości błędów są formuły. Na przykład jeśli formuła pokazuje wartość #N/D lub #ARG!, to komórka, do której odwołuje się dana formuła, może zawierać błąd.

Poniżej przedstawiono listę możliwych przyczyn generowania wartości błędów i stosowanych rozwiązań:

#####

Wartość błędu ##### pojawia się, jeśli komórka zawiera liczbę, datę lub godzinę dłuższą niż szerokość komórki. Można zmienić rozmiar kolumny, przeciągając granicę między nagłówkami kolumn.

#CYKL!

Wartość błędu #CYKL! pojawia się, jeśli formuła bezpośrednio lub pośrednio odwołuje się do siebie samej.

Możliwa przyczyna | Sugerowana czynność
Formuła w komórce bezpośrednio odwołuje się do siebie samej. Na przykład komórka B10 zawiera formułę =SUMA(B5:B10). | Należy sprawdzić odwołania w formule i upewnić się, że nie dotyczą one samej komórki.
Formuła w komórce pośrednio odwołuje się do siebie samej. Na przykład komórka B10 zawiera formułę =SUMA(B5:B9), a komórka B5 zawiera formułę =B10*0,5. | Należy sprawdzić wszystkie komórki, do których odwołuje się formuła i upewnić się, że żadna z nich nie zawiera odwołania do komórki, w której wyświetlany jest błąd #CYKL!. Jeśli którakolwiek z komórek, do których odwołuje się formuła, zawiera formuły, należy się upewnić, że komórki, do których się one odwołują, nie zawierają odwołań do komórki, w której wyświetlany jest błąd #CYKL!.

#DZIEL/0!

Wartość błędu #DZIEL/0! pojawia się, jeśli formuła wykonała próbę dzielenia przez 0 (zero).

Możliwa przyczyna | Sugerowana czynność
Użyto dzielnika odwołującego się do pustej komórki lub komórki zawierającej 0. (Jeśli operand odwołuje się do komórki pustej, to jego wartość jest interpretowana jako 0.) | Należy zmienić odwołanie do komórki lub wprowadzić wartość inną niż 0 w komórce używanej jako dzielnik. W komórce służącej jako dzielnik można wprowadzić wartość #N/D, co spowoduje zmianę wyniku formuły na wartość #N/D oznaczającą, że wartość dzielnika jest niedostępna. Aby zapobiec wyświetlaniu wartości błędu, należy użyć funkcji arkusza kalkulacyjnego JEŻELI. Jeśli dzielnik odwołuje się do pustej lub zawierającej 0 komórki, to funkcja JEŻELI pozwoli wyświetlić ciąg pusty zamiast wartości błędu. Można na przykład użyć zapisu =JEŻELI(B5=0;"";A5/B5). Dwa znaki cudzysłowu reprezentują pusty ciąg tekstowy.
Użyto 0 jako dzielnika, na przykład =5/0. | Należy zmienić dzielnik na liczbę różną od 0.

#N/D

Wartość błędu #N/D pokazuje się, jeśli wartość jest niedostępna dla funkcji lub formuły.

Jeśli określone komórki arkusza kalkulacyjnego będą zawierać dane, które nie są jeszcze dostępne, to można wprowadzić w nich wartość #N/D, aby odwołujące się do nich formuły zwracały wartość #N/D, nie próbując obliczać wartości.

Jeśli potrzebne wartości są dostępne, a wartość błędu #N/D jest nadal wyświetlana, choć powinno jej nie być, to być może przyczyną są specyficzne wymagania funkcji dotyczące argumentów, które nie zostały spełnione lub nieprawidłowe odwołania do wartości w formule lub argumentach funkcji.

Możliwa przyczyna | Sugerowana czynność
Podano nieodpowiednią wartość jako argument szukana_wartość funkcji arkusza kalkulacyjnego WYSZUKAJ.POZIOMO, WYSZUKAJ, PODAJ.POZYCJĘ lub WYSZUKAJ.PIONOWO. | Należy się upewnić, że argument szukana_wartość ma poprawny typ wartości, na przykład wartość lub odwołanie do komórki, ale nie odwołanie do zakresu.
Użycie funkcji arkusza kalkulacyjnego PODAJ.POZYCJĘ z nieodpowiednim argumentem typ_porównania. | Funkcja arkusza kalkulacyjnego PODAJ.POZYCJĘ zawiera argument typ_porównania określający sposób porównywania przez funkcję argumentu szukana_wartość z wartościami argumentu przeszukiwana_tab. Na przykład argument typ_porównania może być tak ustawiony, aby wartość zbliżona lub identyczna była poszukiwana w argumencie przeszukiwana_tab posortowanym w porządku rosnącym, malejącym lub w nieposortowanym. Jeśli funkcja nie może odnaleźć odpowiednika, należy się upewnić, że argument przeszukiwana_tab jest posortowany zgodnie z użytym argumentem typ_porównania i/lub spróbować zmienić argument typ_porównania.
Użycie funkcji arkusza kalkulacyjnego WYSZUKAJ.POZIOMO lub WYSZUKAJ.PIONOWO z argumentem przeszukiwany_zakres ustawionym na wartość FAŁSZ w celu zlokalizowania niedostępnej wartości. | Funkcje arkusza kalkulacyjnego WYSZUKAJ.PIONOWO lub WYSZUKAJ.POZIOMO zawierają argument przeszukiwany_zakres, który nakazuje funkcji odnalezienie dokładnego lub przybliżonego odpowiednika. Jeśli argument ma wartość PRAWDA lub jest pominięty, zwracany jest odpowiednik przybliżony. Innymi słowy, jeśli nie zostanie odnaleziony dokładny odpowiednik, zwracana jest największa kolejna wartość mniejsza od wartości argumentu szukana_wartość. Jeśli argument ma wartość FAŁSZ, funkcja WYSZUKAJ.PIONOWO znajdzie dokładny odpowiednik. Jeśli dokładny odpowiednik nie zostanie odnaleziony, to zwracana jest wartość błędu #N/D. Należy się upewnić, że szukana wartość znajduje się w argumencie przeszukiwana_tab.
Pominięto jeden lub kilka argumentów w funkcji arkusza kalkulacyjnego. | Należy podać wszystkie wymagane argumenty w funkcji.

#NAZWA?

Wartość błędu #NAZWA? pojawia się, jeśli nie został rozpoznany tekst znajdujący się w formule.

Możliwa przyczyna | Sugerowana czynność
Błąd w pisowni nazwy funkcji. | Należy poprawić pisownię.
Wprowadzenie tekstu w formule bez ujęcia go w podwójny cudzysłów. Wpis tego typu nie jest prawidłowo interpretowany jako tekst. | Należy ująć tekst w formule w podwójny cudzysłów. Na przykład poniższa formuła łączy fragment tekstu „Całkowita suma wynosi ” z wartością w komórce B50: ="Całkowita suma wynosi "&B50
Pominięcie dwukropka (:) w odwołaniu do zakresu. | Należy się upewnić, że we wszystkich odwołaniach do zakresu w formule użyto dwukropka (:). Na przykład =SUMA(A1:C10).

#ZERO!

Wartość błędu #ZERO! pojawia się, jeśli zdefiniowano część wspólną dwóch obszarów, które w rzeczywistości się nie przecinają.

Możliwa przyczyna | Sugerowana czynność
Użycie nieprawidłowego operatora zakresu. | Aby odwołać się do dwóch obszarów, które się nie przecinają, należy użyć operatora połączenia, którym jest przecinek (,). Na przykład formuła =SUMA(A1:A10;C1:C10) podsumowująca dwa zakresy, które się nie przecinają, zawiera przecinek oddzielający oba zakresy. Aby odwołać się do dwóch przecinających się obszarów, należy użyć operatora części wspólnej, którym jest pojedyncza spacja. Na przykład formuła =SUMA(B5:C15 A10:D10) oblicza sumę wartości komórek wspólnych dla obu zakresów, tzn. znajdujących się w punkcie przecięcia zakresów B10 i C10.
Użycie nieprawidłowego odwołania do komórki. | Należy sprawdzić, czy w odwołaniach do zakresów nie ma błędów.

#LICZBA!

Wartość błędu #LICZBA! pojawia się, jeśli wystąpi problem związany z liczbą w formule lub funkcji.

Możliwa przyczyna | Sugerowana czynność
Użycie nieodpowiedniego argumentu w funkcji wymagającej argumentu numerycznego. | Należy się upewnić, że w funkcji użyto argumentów właściwego typu.
Użycie funkcji arkusza kalkulacyjnego wykonującej obliczenia iteracyjne, takiej jak IRR lub RATE, jeśli po określonej liczbie prób funkcja nie może odnaleźć wyniku o dokładności w określonym procentowym zakresie tolerancji. | Należy spróbować użyć innych wartości jako argumentu docelowego.
Efektem działania formuły jest liczba zbyt duża lub zbyt mała, aby mogła być reprezentowana w arkuszu kalkulacyjnym. | Wartości w arkuszu kalkulacyjnym muszą zawierać się w zakresie od Minus 1 razy 10 do potęgi 307 do 1 razy 10 do potęgi 307 .

#ADR!

Wartość błędu #ADR! pojawia się, jeśli odwołanie do komórki jest nieprawidłowe.

Możliwa przyczyna | Sugerowana czynność
Usunięcie komórek, do których odwołują się inne formuły lub wklejenie przeniesionych komórek, do których odwołują się inne formuły. | Należy poprawić formuły lub przywrócić komórki w arkuszu kalkulacyjnym, klikając przycisk Cofnij [image] natychmiast po usunięciu lub wklejeniu komórek.

#ARG!

Wartość błędu #ARG! pojawia się, jeśli użyto nieprawidłowego typu argumentu lub operandu.

Możliwa przyczyna | Sugerowana czynność
Wprowadzenie tekstu w formule, która wymaga wartości liczbowej lub logicznej, takiej jak PRAWDA lub FAŁSZ. Tekst nie może być przekształcony na prawidłowy typ danych. | Należy się upewnić, że wartość operandu lub argumentu to odpowiedni typ danych dla formuły lub funkcji, a komórki, do których odwołuje się formuła, zawierają prawidłowe wartości. Na przykład jeśli komórka A5 zawiera liczbę, a komórka A6 tekst „Niedostępna”, to formuła =A5+A6 zwróci wartość błędu #ARG!. Aby dodać te dwie wartości, należy w formule użyć funkcji arkusza kalkulacyjnego SUMA w następujący sposób (funkcja SUMA ignoruje tekst): =SUMA(A5:A6)
Podanie zakresu dla operatora lub funkcji, która wymaga pojedynczej wartości. | Należy zmienić zakres na pojedynczą wartość.
Pominięcie zakresu, gdy jest on wymagany przez funkcję. | Niektóre funkcje, takie jak LICZ.JEŻELI i SUMA.JEŻELI, wymagają podania zakresu. Należy się upewnić, że podano wszystkie zakresy wymaganych argumentów.
Podanie wartości innej niż 1 dla argumentu A1 funkcji arkusza kalkulacyjnego ADRES. | Funkcja ADRES może zwracać tylko odwołania typu A1. Należy zmienić wartość argumentu na 1.
Użycie obliczanych kryteriów — warunkiem jest formuła — dla funkcji baz danych (funkcje D). | Funkcje baz danych dostępne w składniku Arkusz kalkulacyjny nie obsługują obliczanych kryteriów (na przykład "=Pole1<Pole2"). Należy zmienić kryteria na proste warunki, takie jak „Pole1”.
Odwołanie do wielu zakresów za pomocą funkcji arkusza kalkulacyjnego OBSZARY. | Funkcja arkusza kalkulacyjnego OBSZARY nie obsługuje wielu zakresów. Należy utworzyć odwołanie tylko do pojedynczego zakresu komórek.